Can't browse its own shares?!

Hi folks,

We have a 2012 R2 server which cannot browse its own shares. This server has been running without issue for a couple of years, and this started a couple of days ago.

When it tries to access one of its shares it gives the error "Share is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The specified network name is no longer available."

Other PCs can browse the server's shares without issue, using the same domain account.

Windows firewall is off, network discovery is on, SMB v1 is on. I've tried adding a new share with Everyone permissions and I can't access that either. I'm at a loss as to what the issue could be!

Any ideas?

Thanks
Mark TaylorAsked:
Who is Participating?
 
Tom CieslikIT EngineerCommented:
Do you have any antivirus software on this server or any other software that can confuse your route ?
If yes , try disable firewall and AV software for test.

Another idea.

Please change following registry key on the Win 2012 R2 box

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\DependOnService

Original Value: SamSS Srv2

Change to: SamSS Srv

Microsoft did changed Srv to Srv2 with Windows 2012 server but some people reporting issue with share access and only one way is to chage to oldest version.
Please try change it, restart server and check if shares are accessible.

Capture.JPG
0
 
Tom CieslikIT EngineerCommented:
Double check if share are available using server IP like : \\192.168.1.10\Share name
If does then problem is in your DNS settings on server.
Make sure server has DNS set properly.

Try PING server itself and check if it will and try use PING -a IP address and check if ping will return Server Name.
Double check if there is no entries in host file on this serever that is interfering name resolution or IP address
0
 
Fred MarshallPrincipalCommented:
It also sounds like the username being used may not have READ (or other?) access.  
I would look at group membership vs. permissions on the  shares (both sharing and security permissions).
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Mark TaylorAuthor Commented:
Tom, I can use \\hostname on the problem server and it opens. If I use \\ipaddress I get an error (0x80004005 Unspecified Error). If I use \\hostname\share I get an error (The specified network name is no longer available). From other PCs and servers on the network I can access the problem server using any of the above without issue.

DNS looks OK to me. The server addresses are identical to other working servers. I can PING the server address both by name and IP address on the server itself, and from other PCs and servers.

I've looked at hosts and lmhosts.sam in C:\Windows\System32\drivers\etc, but there are no entries there.

Fred, oddly I can access this server from another PC/server with the same account. The shares are very open, for domain users, so not much restricted. I've tried a couple of different accounts, and local admin, on the problem server. All the accounts get this problem.
0
 
Tom CieslikIT EngineerCommented:
Try create new folder and make is share for everyone with full share rights and for test only full security rights.
Check id is working from affected server.

Please let me know.
0
 
Mark TaylorAuthor Commented:
I've created a test share, set to share with Everyone, and security permissions to Everyone (Full Control). I can't browse it, I get the "The specified network name is no longer available." error.
0
 
Mark TaylorAuthor Commented:
Domain firewall is turned off. I've tried disabling AV, but to no avail (it uses System Center Endpoint Protection).

I've changed the registry entry, and will reboot out of hours to see if that helps. Thanks!
0
 
Tom CieslikIT EngineerCommented:
So maybe there is Symantec that blocking you.
If you can;t disable it make sure, that file and printer sharing is enabled and your internal network is in trusted subnets.
0
 
Mark TaylorAuthor Commented:
SCEP is the Microsoft product that comes with System Centre. File and Printer sharing definitely enabled. Will let you know tomorrow re. the registry change.
0
 
Mark TaylorAuthor Commented:
Thanks Tom, very much looks like the registry edit fixed it. Rebooted, and shares are now accessible!
0
 
Mark TaylorAuthor Commented:
Thanks Tom!
0
 
Tom CieslikIT EngineerCommented:
You are very welcome :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.