• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 85
  • Last Modified:

Default Networks display in routing tables

Any Experts to explain the meaning of Default Networks in the routing tables below:

I see "*"  next to C* and D*
what does that mean ?

Thank you

R2#sh ip route connected 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, FastEthernet1/0
L        192.168.12.2/32 is directly connected, FastEthernet1/0
 *    192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C*       192.168.23.0/24 is directly connected, FastEthernet0/0
L        192.168.23.2/32 is directly connected, FastEthernet0/0
R2#

Open in new window


R1#sh ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

D*    192.168.23.0/24 [90/30720] via 192.168.12.2, 00:01:47, FastEthernet0/0
R1#

Open in new window



R1#sh run
Building configuration...

Current configuration : 1213 bytes
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!        
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!        
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !        
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!
!
router eigrp 1
 network 192.168.12.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!        
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R1#


R2#sh run
Building configuration...

Current configuration : 1281 bytes
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!        
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!        
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.23.2 255.255.255.0
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/0
 ip address 192.168.12.2 255.255.255.0
 duplex auto
 speed auto
 !
!        
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!
!
router eigrp 1
 network 192.168.12.0
 network 192.168.23.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip default-network 192.168.23.0
!
no cdp log mismatch duplex
!
!        
!
!
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R2#
0
jskfan
Asked:
jskfan
  • 2
  • 2
1 Solution
 
JustInCaseCommented:
When you are using command
ip default-network 192.168.23.0
It mark network as default network.
* - candidate default
C* - candidate for default network is directly connected interface
D* - candidate for default network learned from EIGRP protocol

Have in mind that default-network command is classfull!

You can find more details in Cisco article - Configuring a Gateway of Last Resort Using IP Commands
1
 
jskfanAuthor Commented:
what does  * - candidate default,  mean in plain english ?

I also see : Gateway of last resort is not set

I thought the main purpose of ip default-network command, is to specify Gateway of Last Resort to other routers.

any clarifications ?

Thanks
0
 
JustInCaseCommented:
* - candidate default - This route may be can be taken into consideration to become default route

is to specify Gateway of Last Resort to other routers
That is the purpose.

Please read INE article - Issues with the “ip default-network” Command
0
 
jskfanAuthor Commented:
Thank you
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now