Link to home
Create AccountLog in
Avatar of maurice cristen
maurice cristen

asked on

Right Click/Proprierties/Unblock what this means?and how to unblock all files automatically?

Right Click/Proprierties/Unblock what this means?and how to unblock all files automatically?
it affects this good run of my application?
http://i68.tinypic.com/5lb8jm.jpg
Avatar of ☠ MASQ ☠
☠ MASQ ☠

If this is your application have you digitally signed it?
Avatar of maurice cristen

ASKER

i use a rdp i connect there and i try to run my app.exe but i notice all files form the folder are locked , why? and this affcets?
i can unlock them manually but takes to long ( i have 40 files inside) i need something automatically and also understand why this hapens?
Unblock is to manually trust a file/remote at locations before you can open them.
unblock manually 40 files? too much :P
This is normal behaviour, app.exe is blocked because its source is untrusted.
RDP can sometime contribute to this as Windows thinks the file is coming from an untrusted source when actually it's the RDP host.
Really need to know more about what you're trying to do to find a solution.  You can globally disable the warning but that has a significant affect on the security of the system.  If you're only dealing with single applications (eg Office) you can change the level of protection for files. As I said above, if this is an app you have created you can digitally sign it and install its certificate on the RDP machine.
There are lots of options
give me best solution some steps, im noob don't explain much plz just give me some steps..1 .2.3 etc
for 1 application i need for this application only i added MYAPP.EXE as exceptions in windows firewall
1. Go into internet options, through control panel or IE.

2. Set the "Launching Applications and Unsafe Files" option to enabled.

This will give you a retarded bar in IE that says your security settings are unsecure or something.

To get rid of it:

1. Start>Run>gpedit.msc>Enter

2. Under Administrative Templates>Windows Components>Internet Explorer set the "Turn Off the security settings check feature" to enabled.

If you don't have Internet Explorer under windows components:

1.  right click Administrative Templates and click "Add/Remove Templates"

2. Click Add button

3. Navigate to "C:\WINDOWS\system32\GroupPolicy\ADM\"

4. Hold shift and highlight all the files that start with "inet"

Source: https://social.technet.microsoft.com/Forums/windows/en-US/e3008c75-48b4-4a6c-bc14-5a20ce72cd7f/disable-open-file-security-warning?forum=itproxpsp
mmm this can't be done with a batch file? make this changing in REGEDIT ? one click as admin and solved ?i need soemthing fast not open 100 windows
It is not a firewall setting.

It is a take it or leave it option.

If you disable the warning, you will not see any blocking but you are at risk.

If you do not disable the warning, it is troublesome but you are not at risk.
mmm this can't be done with a batch file?
No
make this changing in REGEDIT ?
No
one click as admin and solved ?i
No
need soemthing fast not open 100 windows
No such option as it is a setting on local group policy. Just take it or leave it.
in risk? what risk? if i unblock with a command  only my folder files ?
windows fireall block everything and is ON
if i unblock automatically or manualyy all my app. files then my app will run ok?
The risk is any malware will run on its own without your knowledge or approval.
There is no automatic way to do unblock. Once you manually unblock a file, you do not need to unblock it again in the same computer.
i followed this:

1. Start>Run>gpedit.msc>Enter

2. Under Administrative Templates>Windows Components>Internet Explorer set the "Turn Off the security settings check feature" to enabled.

now i check my folder files and have same state: UNBLOCK
There is no automatic way to do unblock. Once you manually unblock a file, you do not need to unblock it again in the same computer.

QURSTION: is there a script to unblock them automatically all 45 and not manually unblock until christmass come?
If you are opening the file in remote computer, you need to change the local group policy of the remote computer.
i set to enable this:
1. Start>Run>gpedit.msc>Enter

2. Under Administrative Templates>Windows Components>Internet Explorer set the "Turn Off the security settings check feature"

Open in new window


than i check my folder and i see there same situation, UNBLOCK option is still there
Have you restarted the computer?
nah..if i restart that rdp maybe server will stay DOWN i can't risk if i can't find something to do this automatically...UNBLOCK all my folder files then i will do this manually
ASKER CERTIFIED SOLUTION
Avatar of maurice cristen
maurice cristen

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
thx