Network Advertisement in EIGRP

I have 2 routers  R1 directly connected to R2. R1 has a loopback interface with ip address 1.1.1.1/32
However in EIGRP when I advertised the loopback network  I used:
router eigrp 1
 network 1.1.1.0 0.0.0.255

Now if I go to R2 routing table I see that route showing as:
R2#sh ip route eigrp
Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/156160] via 192.168.12.1, 00:06:20, FastEthernet0/0

***I thought it would show as /24 instead 32

Any idea ?

Thank you
jskfanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
Network command is only marks range of IP addresses that can be advertised into EIGRP. This does not tell anything about networks that will be advertised. Networks that will be advertised are actually network(s) that are matching to IP address and subnet that is configured under interface(s).

For example
interface fa0/0
 ip address 192.168.0.1 255.255.255.0
!
! Cisco recommends
router eigrp 1
 network 192.168.0.1 0.0.0.0

Open in new window

This means - advertise network(s) that is configured on interface with IP address 192.168.0.1, but it will advertise network 192.168.0.0/24.

interface fa0/1
 ip address 192.168.1.18 255.255.255.192
!
interface fa 0/2
 ip address 192.168.1.126 255.255.255.248
!
interface  fa 0/3
 ip address 192.168.1.200 255.255.255.128
!
router eigrp 1
 network 192.168.1.1 0.0.0.127

Open in new window


Means - check all interfaces that have configured IP address in range 192.168.1.0-127 and advertise network ranges configured under interfaces.
Networks 192.168.1.0/26 and 192.168.0.120/29 will be advertised in EIGRP, but network 192.168.1.128/25 will not be since IP address 192.168.1.200 does not belong to IP address range for matching addresses.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hemil AquinoNetwork EngineerCommented:
Aside of predrag comment which is well formulated, I will give you another straight up answer.

The reason why it shows 32 bit mask instead of 24 is because you have configured the Loop-back interface with only one host. (1.1.1.1/32).
Remember, router knows about what you have in your network. So even though you have set the command: "network 1.1.1.0 0.0.0.255" it doesn't means EIGRP will send a 24 bit mask to the next neighbor.  EIGRP will tell the next neighbor, here is my network which is what you have embedded in your interface of R1.
Don JohnstonInstructorCommented:
Here's how I explain it:

The network statement is used to indicate which interfaces are participating in the routing process.  "Participating" does two things:
1) If an interface is participating, the connected network will be advertised through the routing protocol.
2) A participating interface will attempt to form adjacencies with other routers on that interface.

In your case, the "network 1.1.1.0 0.0.0.255" statement tells the router that any interface with an IP address of 1.1.1.anything is a participating interface.  Since it's a loopback, there are obviously no other routers connected to that interface. But the network that interface is connected to will be advertised to other EIGRP routers. However, you used a /32 mask.  Which means the "network" is 1.1.1.1/32.  Had you assigned an IP address of 1.1.1.1/16 to the interface, then the neighboring routers would have learned of the 1.1.0.0/16 network instead.

In summary, in EIGRP (and OSPF, IGRP and RIP), the network statement doesn't specifically define how a network is advertised. It defines which interfaces are participating in the routing protocol.

HTH
Get Cisco Certified in IT Security

There’s a high demand for IT security experts and network administrators who can safeguard the data that individuals, corporations, and governments rely on every day. Pursue your B.S. in Network Operations and Security and gain the credentials you need for this high-growth field.

jskfanAuthor Commented:
Ok..I have not tested it yet, but I will later.

For instance , if I have  R1 loopback interfaces :
192.168.0.1/24
192.168.1.1/24
192.168.2.1/24
192.168.3.1/24

Then I advise in EIGRP :
 Network 192.168.0.0/24
 Network 192.168.1.0/24
 Network 192.168.2.0/24
 Network 192.168.3.0/24

How is it going to show in the neighbor R2 Routing table . R2 is also configured with EIGRP

Thanks
JustInCaseCommented:
Neighbor will see
Network 192.168.0.0/24

 Network 192.168.1.0/24
 Network 192.168.2.0/24
 Network 192.168.3.0/24
Also, it will end result be the same in the case that EIGRP is configured as:
router eigrp 1
 network 192.168.0.1 0.0.0.0
 network 192.168.1.1 0.0.0.0
 network 192.168.2.1 0.0.0.0
 network 192.168.3.1 0.0.0.0
or
router eigrp 1
 network 192.168.0.1 0.0.3.255
or
router eigrp 1
network 0.0.0.0 255.255.255.255

End result is always the same. Always are advertised networks configured under interfaces.
Don JohnstonInstructorCommented:
How is it going to show in the neighbor R2 Routing table

192.168.0.1/24
192.168.1.1/24
192.168.2.1/24
192.168.3.1/24

But once again, the network statement in EIGRP doesn't specifically say to advertise these exact networks.

In EIGRP, you could have used the network statement

network 192.168.0.0 0.0.255.255

and it would have the EXACT same result as

network 192.168.0.0 0.0.0.255
network 192.168.1.0 0.0.0.255
network 192.168.2.0 0.0.0.255
network 192.168.3.0 0.0.0.255

Because the network statement doesn't tell the router what to advertise.  It tells the router which interfaces are participating in EIGRP.
jskfanAuthor Commented:
Thank you Guys
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.