Error: The password you entered doesn't meet minimum security requirements.

Using Exchange 2013 Standard on premise with Active Directory on another server. I keep getting the same error when I use the change password function: The password you entered doesn't meet minimum security requirements. Am I missing a configuration.
I ran this command on the Exchange Server: Get-OwaVirtualDirectory |fl *pass*
Got this: ChangePasswordEnabled : True

I also ran this command on the server and set the GPO password settings way down to get this to work:  net accounts

C:\Windows\system32>net accounts
 Force user logoff how long after time expires?:       Never
 Minimum password age (days):                          30
 Maximum password age (days):                          180
 Minimum password length:                              1
 Length of password history maintained:                24
 The command completed successfully.

The password complexity is disabled.

I entered this password: a1cs6nx.2T   and still got the "The password you entered doesn't meet minimum security requirements."  Doesn't make sense.

What is next?
LVL 1
cyberservicesAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hemil AquinoNetwork EngineerCommented:
I could explain this to you. But I have found this link that will give you the exact solution.
https://anishjohnes.wordpress.com/2014/09/05/user-unable-to-reset-password-from-exchange-2010-owa/

Try it out.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Shaun VermaakTechnical SpecialistCommented:
Is it the first time you assign that password?
For a test set the minimum password age to 0
0
McKnifeCommented:
1st: where did you execute the net accounts command? If you executed it on the exchange server, you should add /domain or it will not show the password policy for the domain but the local password policy, instead.
2nd password settings objects might be active and those PSO's override domain password policies.
0
Acronis Data Cloud 7.8 Enhances Cyber Protection

A closer look at five essential enhancements that benefit end-users and help MSPs take their cloud data protection business further.

cyberservicesAuthor Commented:
The password used was the first time ever. I executed the net accounts command from a workstation.
I set the minimum to 0 and tried again with a brand new password. Still the same result. I will now take a look at the link above.
0
McKnifeCommented:
" I executed the net accounts command from a workstation" - useless. Please do as suggested and find out what the current domain password policies are and whether a PSO applies.
0
cyberservicesAuthor Commented:
Do I need to execute the command from the Exchange Server or the Domain Controller?
0
McKnifeCommented:
You just need to add /domain.
net accounts /domain

Open in new window

To find whether a PSO applies to "Username":
On the powershell, execute
Get-ADUserResultantPasswordPolicy Username 

Open in new window

0
serialbandCommented:
How many minimum characters are you supposed to use?  Try adding 2 more characters.  10 characters are actually insufficient these days.  You need at least 12 characters to stay ahead of the computer power to crack passwords in the allotted time frame now.
0
cyberservicesAuthor Commented:
I ran this command Get-ADUserResultantPasswordPolicy Username  replacing the username with the account name in windows powershell. It just went to the next line with now info. What did I miss?
0
cyberservicesAuthor Commented:
The other command net accounts /domain  gave me all the correct information to include: computer role  primary
0
McKnifeCommented:
If the powershell command returns nothing, then no PSO is applied.
If the /domain command returns the same, then you are looking at the actual pw policies. That can only mean, that you forgot about the minimum password age of 30 days.
0
cyberservicesAuthor Commented:
I set the ‘Minimum Password Age‘ policy to zero. As soon as I did this I was able to change the password!!! Finally.
I'm now changing the history to 24 and the minimum to 12 and retest.
0
cyberservicesAuthor Commented:
I set the minimum to 12 and ran tests. All other settings worked. The only one that was causing the issue was password age has to be 0.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.