Link to home
Create AccountLog in
Avatar of sf1elds
sf1eldsFlag for Barbados

asked on

Exchange 2016 OWA Log on UPN format won't work

I'm trying to set my OWA login option to UPN format. However it seems not to work even though I've set it to that format in authentication. See attached.

I'm trying to use the following format | username@domain.com

Only this format works | domain\username

I've also restarted the IIS.
EXCHANGE-2017-11-13-08-59-46.png
Avatar of CES
CES

You need to change the forms-based authentication format.

in the ECP, go to Servers > Virtual Directories.  Open the OWA virtual directory and then go to Authentication.  Change the radio button under forms based authentication to meet your needs.

You may need to restart IIS to get this to take effect.
Did you try after reseting  IIS
iisreset/noforce
Avatar of sf1elds

ASKER

@ CES IT: I did exactly that, I included a screen shot in my question.

@ MAS: Yes I did that.
Check you user object(s) that their UPN is actually set to what you think it is, and is not the netbios name for the domain. (i.e your email address is not your UPN)
Does the CAS serve you are logging into hate a global catalog server in the same site/subnet object in AD?
Avatar of sf1elds

ASKER

@Pete: Totally lost as to what your trying to say here. "Check you user object(s) that their UPN is actually set to what you think it is, and is not the netbios name for the domain. (i.e your email address is not your UPN)
Does the CAS serve you are logging into hate a global catalog server in the same site/subnet object in AD?"
For testing please change it back to "Username only"  and make sure OWA VDs works fine.
User generated image
SOLUTION
Avatar of Tom Cieslik
Tom Cieslik
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of sf1elds

ASKER

It works fine with 'username only'. Tried that already.
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Avatar of sf1elds

ASKER

I just tried logging on to the OWA from the local network using "username@domain.local" and that worked.
That's why because you domain.local is recognized and your External domain don't.
Avatar of sf1elds

ASKER

@MAS Ok you maybe onto something here. When I go to user properties I'm only seeing "@domain.local". How do I add "@domain.com"?
This was the point I was trying to make above?

P
That's why I was asking you if external domain name is registered in your Doman. :)

To add UPN suffixes
Open Active Directory Domains and Trusts. To open Active Directory Domains and Trusts, click Start , click Administrative Tools , and then click Active Directory Domains and Trusts .
In the console tree, right-click Active Directory Domains and Trusts , and then click Properties .
On the UPN Suffixes tab, type an alternative UPN suffix for the forest, and then click Add .
Repeat step 3 to add additional alternative UPN suffixes.