Ad upgrade

Hi All,

We have three domain controllers (1 - Server 2008 R2 and 2 - Server 2008). Our domain and Forest levels are Server 2008.

We are in the process of introducing Server 2016 as domain controller. When I run adprep /Forestprep from server 2016 iso on our PDC Server 2008 R2, I keep getting the following error. I have added my account to Enterprise and Schema admins groups. Has anyone come across this issue?

Adprep detected that the supplied or default user is not a member of the followi
ng group: Enterprise Admins group and Schema Admins group.
[Status/Consequence]
Adprep has stopped without making changes.
[User Action]
Verify the user is a member of Enterprise Admins group and Schema Admins group.
LVL 1
skyjumperdudeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
When I run adprep /Forestprep from server 2016 iso...

you don't run adprep anymore; deprecated since 2012
when you add the role, it will prepare the schema automatically as needed
0
skyjumperdudeAuthor Commented:
So I don't need to run adprep for Forest, Domain and grouppolicy?
0
Lee W, MVPTechnology and Business Process AdvisorCommented:
While Seth is correct, when you added your account to those groups, did you log off and log on?  Adding yourself to those groups does not update the security token - that's set at logon.  You need to log off and on again for Windows and (likely that process) to know you are a member of that group.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Seth SimmonsSr. Systems AdministratorCommented:
yes, that was the second part of the issue before i got distracted
you need to be part of those 2 groups to add the role

So I don't need to run adprep for Forest, Domain and grouppolicy?

no
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.