Configure Citrix WebInterface 5.4 to XenApp 7.15

Hi All,

I know this is not supported but, Is there any way to configure WebInterface 5.4 to XenApp 7? If so, Do I need to install StoreFront? How does the XenApp Studio linked to WebInterface? Basically, we would like to use WebInterface just because we need to use the Secure Access - Network Translation feature which is not longer seen in StoreFront.

Nitsan
Nitsan ReznikIT Consultant Asked:
Who is Participating?
 
Carl WebsterConnect With a Mentor Commented:
Using Web Interface 5.4 with XA/XD 7.x is supported. In WI where you would enter a data collector name, enter the name of a delivery controller. That is it.
0
 
Carl WebsterCommented:
https://support.citrix.com/article/CTX130917

Go down to the Configuring Web Interface section,
0
 
Nitsan ReznikIT Consultant Author Commented:
Thank you all for your comments. So, all I need to do is to install XenApp 7 roles apart from Storefront right? and then install WI 5.4? Or shall I install WI 5.4 first?
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
Carl WebsterCommented:
Makes no difference in what order you install. You can configure WI until you have a fully configured Site with a delivery controller.
0
 
Nitsan ReznikIT Consultant Author Commented:
Thank you. Will let you know if we encounter any issues.
0
 
Nitsan ReznikIT Consultant Author Commented:
Hi,

I followed the link your provided and installed WI 5,4 and XenApp 7.15 and when accessing the site I keep getting the following error:
Internal Error


The Web site is experiencing technical difficulties. We apologize for any inconvenience.

The internal error may only be temporary. Try reconnecting and, if the problem persists, contact your system administrator.

Event viewer shows: ASP.NET 4.0.30319.0 error:

Event code: 3007
Event message: A compilation error has occurred.
Event time: 11/13/2017 10:01:20 PM
Event time (UTC): 11/13/2017 10:01:20 PM
Event ID: daf1d3b6be344d1093fefa29c818ae8f
Event sequence: 3
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/1/ROOT/Citrix/XenApp-2-131550840797020883
    Trust level: Full
    Application Virtual Path: /Citrix/XenApp
    Application Path: C:\inetpub\wwwroot\Citrix\XenApp\
    Machine name: CITRIX

Process information:
    Process ID: 3700
    Process name: w3wp.exe
    Account name: IIS APPPOOL\CitrixWebInterface5.4.0AppPool
0
 
Nitsan ReznikIT Consultant Author Commented:
Managed to fix above issue and installed VDA server OS and now whenever I logged in, I keep getting There are no resources currently available for this user even though I have made sure it's an Administrator and Machine is registered under delivery group. The funny thing is that there's no event viewer errors or warning. Please advice.
0
 
Carl WebsterConnect With a Mentor Commented:
"Secure Access - Network Translation feature which is not longer seen in StoreFront."

That does not work with XA/XD 7.x. You need to use NetScaler. There is a free version that just needs to be relicensed every year.
0
 
Carl WebsterCommented:
Citrix does support using Web Interface with XenApp/XenDesktop 7.x but does not support the old Adress Translation or Secure Gateway access methods.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.