Outlook 2016/Exchange 2013 users Disconnecting

Hi Everyone

We are currently having an intermittent situation whereby our end users are sporadically being disconnected.  We believe we have pinned it down to the MSExchangeRpcProxyFrontEndAppPool reaching its Private Bytes memory limit and then doing an automatic App Pool recycle and that this is then disconnecting our users.  The Private Memory limit is set to about 1.5GB.  Once it fills it forces an app recycle, kicking everyone connected to that process off.  We see Event ID 5117 in system log followed by two events 5138, 5013.  These appear to be IIS related

Has anyone else encountered this issue, and if so how did you overcome it.  Are we ok to increase that limit or even set it to 0 (unlimited) or are there any alternatives to resolve this and avoid disconnections.

Thanks

Fingwong
Fing wongAsked:
Who is Participating?
 
AmitIT ArchitectCommented:
I don't see any harm in changing the IIS setting, as per your environment.  Something similar discussed here also:
https://blogs.msdn.microsoft.com/ashishsingh/2010/04/02/too-frequent-application-pool-recycling-in-iis-can-lead-to-unexpected-issues/

If you have option to open MS case, I would highly recommend to check with MS too. Might be, they released any interim fix for this issue on Exchange server.

Let me know, if any more query.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.