Exchange NDR error: 550 5.1.1

I had a public folder that I deleted yesterday, I first disabled the email address on it,  and then deleted the folder.
I then created a mailbox, with the same email address.

Now when I try to email the new account, I get these errors.  Is there a manual way to update exchange, or what would I need to do to refresh exchange, or remove any of the old pointers to the public folder?

Delivery has failed to these recipients or groups:
DonorRelations
The email address you entered couldn't be found. Please check the recipient's email address and try to resend the message.
If the problem continues, please contact your helpdesk.

Diagnostic information for administrators:
Generating server: ELIJAH.mydomain.org
IMCEAEX-_CN=Mail+20Public+20Folder_CN=Version+5F1+5F0_CN=3c14ab36-6368-48ed-9263-dc9fa42f04f7_CN=00000000D
F3907BF85C4AC4B86B4C6F77C575B740100D4DCFC0B6DD13947B7CD23D1F9A699860001C52FC1F50000@mydomain.org
Remote Server returned '550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found'
Original message headers:
Received: from ELIJAH.mydomain.org (192.168.100.131) by
 elijah.mydomain.org (192.168.100.131) with Microsoft SMTP Server (TLS) id
 15.0.1156.6; Tue, 14 Nov 2017 08:40:30 -0800
Received: from ELIJAH.mydomain.org ([fe80::97d:771a:ed09:476]) by
 elijah.mydomain.org ([fe80::97d:771a:ed09:476%12]) with mapi id
 15.00.1156.000; Tue, 14 Nov 2017 08:40:30 -0800
Content-Type: application/ms-tnef; name="winmail.dat"
Content-Transfer-Encoding: binary
From: Dan Andries <dan@mydomain.org>
To: DonorRelations <DonorRelations@mydomain.org>
Subject: test
Thread-Topic: test
Thread-Index: AdNdZ0fAM8YWEoyAT0qN9JJQH0yK6A==
Date: Tue, 14 Nov 2017 08:40:30 -0800
Message-ID: <f9216d42b63c45139641aea2037ce0bb@elijah.mydomain.org>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator: <f9216d42b63c45139641aea2037ce0bb@elijah.mydomain.org>
MIME-Version: 1.0
X-MS-Exchange-Transport-FromEntityHeader: Hosted
X-Originating-IP: [192.168.102.10]
Return-Path: dan@mydomain.org
DanNetwork EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hemil AquinoNetwork EngineerCommented:
This issue may occur if the on-premises mail-enabled user who represents the moved mailbox isn't stamped correctly with the target address. The Exchange server generates an NDR message because the on-premises Active Directory Domain Services (AD DS) can't locate the user in order to route the mail correctly.

1- Open the Exchange Management Console on your local Exchange 2010 server.
2- Click Microsoft Exchange On-Premises, and then click Recipients Configuration.
3- Right-click the user, and then click Properties.
4- On the E-mail Addresses tab, click Add, click SMTP Address, and then enter the email address. Use the alias@domain .mail.onmicrosoft.com format for the email address.
5- Select the name that you entered, and then click Set as Routing Address.
6- Click OK.
DanNetwork EngineerAuthor Commented:
I actually have exchange 2013, but no worries, I forgot to mention that. So I did what you said, I believe you wanted to make sure I have checked the checkmark where it updates the emailaddress based on the email policy in place.  

But it's still not working, I keep on getting the bounce back.

dr
Hemil AquinoNetwork EngineerCommented:
Oh ok, but I need to ask you something before move further into this.
Did you delete the cache of that email in your computer? meaning when you type the email address in outlook then the auto complete list appear, you need to deleted, close outlook and re-enter that user.

Try that and see how it goes.
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

DanNetwork EngineerAuthor Commented:
yes, I did delete the outlook autocomplete cache.
Hemil AquinoNetwork EngineerCommented:
Did you try using a different machine to send a test email to that specific address. Please do that, because you hint it's just right here

I had a public folder that I deleted yesterday, I first disabled the email address on it,  and then deleted the folder.
I then created a mailbox, with the same email address

That happened to me and it turned out that my machine was holding the cache of my email somehow.
DanNetwork EngineerAuthor Commented:
yes, I just did a test from a laptop, and I'm getting the same problem.
It's not a problem with my local machine, the problem is with my AD.
My AD is still pointing to the old public folder.
Hemil AquinoNetwork EngineerCommented:
The error message #550 5.1.1 means the following:

1. The recipient email address was entered wrongly. -- Which I believe you've checked.
2. No such recipient is present in the destination email system.
3. The recipient mailbox has been moved.
4. An invalid legacy domain name exists for the recipient mailbox Active Directory.

I would like to confirm whether you were able to deliver mails to this domain earlier, or received Non-Delivery Report (NDR) in recent times.
If yes, you can contact the recipient and confirm if they have altered or configured their domain or Active Directory settings.

Here is the last method

Warning This procedure requires ADSI Edit. Using ADSI Edit incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems that result from the incorrect use of ADSI Edit can be resolved. Use ADSI Edit at your own risk.

Click Start, click Run, type adsiedit.msc, and then click OK.
Locate and right-click the user, and then click Properties.

Note To determine the container to which the user belongs, view the user properties in the Exchange Management Console.
Click the Attribute Editor tab, and then double-click Target Address.
Type the external Simple Mail Transfer Protocol (SMTP) address.
Click OK.
After the service routing domain is set up, confirm that the issue is resolved.
DanNetwork EngineerAuthor Commented:
so I know for sure it's not #1 or #2 from your list.  It's either #3 or #4, I know for sure.

So yesterday, the email donorrelations@mydomain.org was a public folder and it was working fine, multiple people internally and externally was able to send emails to it.  The department supervisor did not want a public folder, but wanted that to be a mailbox, so email can be in the mailbox and also be forwarded on to someone else as well.

So I disabled the mail-enabled public folder called donorrelations (which had that email address), and then then deleted the folder.  Then I created a mailbox called donorrelations@mydomain.org
When I did some tests last night, it seemed to work,

I just did an external test and that works, so I can send an email from my gmail.com account to donorrelations@mydomain.org
But all my internal emails are failing.  This is strange.
Hemil AquinoNetwork EngineerCommented:
I've found this. I never tried but you might give a shot

Went to the properties of the user.
Navigated to the e-mail address tab.
“Add” a new “Custom Address”
Filled in “type” as “X500″ and edited the massager address from outlook as per below and entred it as the address
DanNetwork EngineerAuthor Commented:
I figured out the problem, here's what I did that worked.  I think the secret was to wait, from the time I performed the update global address list, it takes a few hours it looks like, as I've deleted my local cache and the public folder was still coming up in my global address list.  After a few hours, I did it again and it worked.  So I had to wait.  Here's what I did.

      1. In exchange management shell, run the following command, Get-GlobalAddressList|Update-GlobalAddressList
      2. Then wait about 2-3 hours
      3. Then delete the outlook autocomplete cache on the local machines
      4. Then download the newest GAL in outlook,
            a. Click on send/receive
            b. Click on send/receive groups
            c. Click on Download address books
            d. Uncheck the box "download changes since last send/receive", so it can download the entire GAL, click ok

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hemil AquinoNetwork EngineerCommented:
That's good man. Keep a log of that.
DanNetwork EngineerAuthor Commented:
yes, thank you sir... I use onenote, and I added it to my one note !
DanNetwork EngineerAuthor Commented:
Thanks Hemil for your help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.