• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 69
  • Last Modified:

VMWare Disk Full

Hi
I have a ESXi Host V 6 running with 4 virtual servers.

One of the servers will not start as it says the allocated disk size is full. I cannot even restart it in Safe Mode.
I have tried to increase the disk size as the VM Client says there is still 175Gb of unallocated space. But if i try and extend the disk it says it is full.
These are not thin installs
How do i get onto the Virtual Server to delete some files?
0
Optima Systems
Asked:
Optima Systems
1 Solution
 
John TsioumprisSoftware & Systems EngineerCommented:
How about using a bootable Linux/WinPE cd image in order to get the VM disk mounted and then handle it...
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You will need to inspect the datastore if the datastore storage is full ?

do you have any snapshots on the datastore which could be deleted ?
0
 
Optima SystemsNetwork EngineerAuthor Commented:
I dont have any snap shots available. I have rebooted the Host Server and it is registering that there is only 45Gb free space available. However, i sill cannot allocate this within the Edit Settings for the Terminal Server as it says there is no additional space.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Can you screenshot the disk settings ?

if you only have 45GB available on the datastore, you should not use it all, and make sure you reserve 20%.

When you power on a VM, it creates a swap file equal to memory assigned in the VM.
0
 
Ajay ChananaMCSE-2003/08|RHCSA| VCP5/6 |vExpert2018Commented:
From the description it clearly shows that this is thin provisioned disk to the client but at the same time you cannot expand the disk as datastore is full.

You don't require to get into VM but need to free up space on the datastore. You might not be able to move or consolidate VM if datastore have zero space.

These are the steps you can do to fix:-
1# Move few VM's out of the datastore to get some space.
2# Delete the snapshots of you have on any VM on the datastore.
3# IF you have zero space on datastore, you still can get some by deleting vmware.logs and consolidate.
4# Increase the datastore space (Depends on what datastore you have its have different resolution)
5# clone the VM to different datastore, this will automatically consolidate VM also.
0
 
Optima SystemsNetwork EngineerAuthor Commented:
Hi
Thank you all for the comments. Although we found there was potentially additional space for the datastore we could not utilise the free space and the Server required us to access the OS to be able to expand the server's disk into the free space. The server would not boot to a logon screen whatever we tried.
This is a Terminal Server for 10 people. They have Office 365 and all the data was backed up. We decided to delete the VM and rebuild the Virtual Server from scratch.
All looking good now. Thanks.
PS we found that the error was created by a few users deciding to change their Outlook Cached Mode form 12 months to "everything" this filled the Server overnight as they were users who had huge mailboxes.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now