sql server express on domain controller

Hi, I need install sql server express on domain controller.
The propose is install ADMT 3.2.
the installation finish, but cannot start the service.
Any idea?
Oscar TroncosoNetwork AdministratorAsked:
Who is Participating?
 
Daniel_PLDB Expert/ArchitectCommented:
How did you install this instance then? You can fix these paths by editing startup parameters. Simplest way is to go to SQL Server Configuration Manager, click on SQL Server Services. Right click you SQL Server Express Instance, choose properties, then pick startup paramters tab. Edit each by putting correct path to each folder. Please note there are no spaces between parameter and path.

Regards,
Daniel
0
 
John TsioumprisSoftware & Systems EngineerCommented:
Have you tried to start the service manually...have you check the Event log for errors when you try to start the engine
0
 
Daniel_PLDB Expert/ArchitectCommented:
Hi,

You can't use Network Service or Local Service account for your SQL Server, what account did you choose?

Additionally, SQL Server is not supported on ReadOnly domain controller:
https://support.microsoft.com/en-us/help/2032911/you-may-encounter-problems-when-installing-sql-server-on-a-domain-cont

Regards,
Daniel
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Oscar TroncosoNetwork AdministratorAuthor Commented:
The sql server express is not installed on RO DC
Attach Event viewer errorssql server express starting servicesqlserver express event viewer1sql server express event viewer1thks
0
 
Daniel_PLDB Expert/ArchitectCommented:
Hi,

Your service sid account doesn't have access to it's data folders. I suggest to start off on E: drive. Add NT SERVICE\MSSQL$SQLEXPRESS user to list. Then, it depends on an inheritance settings, but I suggest to grant aforementioned account read & execute, list folder contents, read (the same as on root E: drive). These should stay until you get into DATA and LOG directories, both should be granted under FullControl to the SQL Server account.

Regards,
Daniel
0
 
Oscar TroncosoNetwork AdministratorAuthor Commented:
Daniel_PL My system not have a Drive E: only C:
thanks for you reply, Anyway, I'm going to check the logs
0
 
Vitor MontalvãoMSSQL Senior EngineerCommented:
Looks like SQL Server wasn't properly installed. If drive E: doesn't exists, it existed during the installation and now it's complaining about it.
Perhaps best thing to do is to reinstall.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.