Gmail SMTP email server settings for WSUS notifications needed

I'm currently using a Gmail account for Veeam email notifications using the server addresses shown in the first screenshot and am successfully receiving Veeam email notifications.

However when I try to use the exact same Gmail email address and email server settings for Server 2016 WSUS email notifications (in the second and third screenshots) these email server address notifications don't work. I receive the error message shown in the last screenshot which says

"System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.0 Must issue a STARTTLS command first. i8sm33761833pgq.67 - gsmtp
   at Microsoft.UpdateServices.Internal.BaseApi.SoapExceptionProcessor.DeserializeAndThrow(SoapException soapException)
   at Microsoft.UpdateServices.Internal.DatabaseAccess.AdminDataAccessProxy.SendTestEmail(String emailLanguage, String smtpUserName, String senderEmailAddress, String smtpHostName, Int32 smtpPort, String recipients)
   at Microsoft.UpdateServices.Internal.BaseApi.EmailNotificationConfiguration.SendTestEmail()
   at Microsoft.UpdateServices.UI.SnapIn.Dialogs.EmailNotificationSettingsDialog.backgroundWorker_DoWork(Object sender, DoWorkEventArgs e)."

There is no where within the Server 2016 WSUS email notification settings to select to use secure connection (SSL/TLS).

So what is the correct Gmail email address server address setting to use to successfully send notification emails?


VEEAM-EMAIL-NOTIFICATIONS
WSUS-EMAIL-NOTIFICATIONS
WSUS-EMAIL-NOTIFICATIONS-ADDRESES
TEST-EMAIL-NOtiFICATION-ERROR message
IT GuyNetwork EngineerAsked:
Who is Participating?
 
SeanSystem EngineerCommented:
Add the SMTP role
open IIS 6
Right click and select properties of the SMTP relay
Access Tab: Set the IP for the internal devices in the connection button.
Add the same IP to the Relay list.
Delivery Tab: Set an external domain - This is where you will put the gmail information.
Allow port 25 (or whatever email port you want) through the firewall on the server
Set the smtp service to automatic and do a restart of the service and you should be all set. Here is a detailed write up as well.

http://blog.powerbiz.net.au/exchange/how-to-set-up-an-internal-smtp-service-for-windows-server-2012-essentials/
0
 
SeanSystem EngineerCommented:
I would suggest setting up an internal email relay using IIS. It's very easy and you can point that to gmail. The problem is that gmail requires SSL/TLS and the wsus server doesn't have that as an option which is why it's failing.
0
 
IT GuyNetwork EngineerAuthor Commented:
Can you please provide me with the instructions on how to set up an internal email relay using IIS?
0
 
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
It appears you're trying to use Gmail for relaying + as I understand, they've retired this facility.

If you're looking for a cheap relay, use MailGun. Its cheap + reliable + easy to debug.

First 10K messages each month are free, so you pay nothing for low volume email.
0
 
SeanSystem EngineerCommented:
David, he isn't using their open relay he is using authentication. This isn't retired.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.