Cannot Change IE Security Settings on RDS server

I have installed a clean Server 2012R2 server, joined it as a member server, installed RDS ran all patches. I am trying to set the IE Internet zone to medium High.  The sites button is greyed.  The Custom slider is not there.  Custom Level button is available but the only Level available is High (default).

I have checked HKLM and HKCU for the Control Panel Internet settings. Keys/entries do not exist.
    HKEY_CURRENT_USER \ Software \ Policies \ Microsoft \ Internet Explorer \ Control Panel
    and
    HKEY_LOCAL_MACHINE \ Software\ Policies \ Microsoft \ Internet Explorer \ Control Panel
    HKEY_LOCAL_MACHINE \ SOFTWARE \ Policies \ Microsoft \ Windows \ CurrentVersion \ Internet Settings

I have verified no GPO Domain or local exists preventing changes.

I have set the registry value for the zone(s) to 1, no difference.  Restarted server.

Added a Local GPO to allow changes (option is set to disable).  

I'm at a loss now.  Please help.
David BirdPartnerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

John TsioumprisSoftware & Systems EngineerCommented:
How about installing another browser and dumping IE...
0
yo_beeDirector of Information TechnologyCommented:
It sound like you have Group Policy settings being applied for the users

Do you know where to look for this.

User Config > Administrative Templates > Windows Components > Internet Explorer.  

Check there to see if anything is enabled.

Also run RSOP from CMD
0
David BirdPartnerAuthor Commented:
Hehe. It's quickbooks fussing at the Internet security Settings.  Have Firefox as default.
Ran GPResults with no GPO under domain or local.  Created a LOCAL GPO setting to make sure is was enabled.  Ran gpresult again and it showed the local policy and successfully loaded.
0
Simple Misconfiguration =Network Vulnerability

In this technical webinar, AlgoSec will present several examples of common misconfigurations; including a basic device change, business application connectivity changes, and data center migrations. Learn best practices to protect your business from attack.

yo_beeDirector of Information TechnologyCommented:
I just looked at my local computer and the Internet Zone > Site button is greyed out.   This maybe by design.  Looking at this KB from MS you will see that they just mention Intranet, Trusted and Restricted for the Site button.  Nothing about the Internet.  Can you confirm that the Internet Zone > Site button is not greyed out on your computer?

https://support.microsoft.com/en-us/help/17479/windows-internet-explorer-11-change-security-privacy-settings





Add or remove a site from a security zone
 
 1.Open Internet Explorer, select the Tools button , and then select Internet options.
2.Select the Security tab, choose one of the security zone icons (Local intranet, Trusted sites, or Restricted sites), and then select Sites. You can add sites to the zone you chose, or delete sites that you no longer want in this zone.

3.If you chose Local intranet in the previous step, select Advanced, and then do one of the following:
•Add a site. Enter a URL into the Add this website to the zone box, and then select Add.
•Remove a site. Under Websites, select the URL you want to remove, and then select Remove.


0
David BirdPartnerAuthor Commented:
Therein lies the whackadoodle part.  On my DC running 2012R2, The Sites button is enabled AND the slider bar is there.  Just the new machine has the Internet / Site greyed out.
0
David BirdPartnerAuthor Commented:
I got it.  In one thread I was reading, the IT Enhanced security had to be disabled (which it already was today).  But I wondered if it wasn't all happy in the registry and looked up the location. BUT, before I went off the deep end on it, I just turned IE Enhanced back on, opened closed Internet explorer, then turned IE Enhanced back OFF.  Opened Security tab and all was good.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
yo_beeDirector of Information TechnologyCommented:
That is very interesting.  I just checked on my home computer that has no GPO's applied and the Site button is also greyed out.
0
David BirdPartnerAuthor Commented:
The fix I posted in the forum worked.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.