Understanding Route Map

I have  router R1 connected to router R2.
R1 has some loopbacks and the networks that the loopbacks are on, are advertised to EIGRP

R1 has some Networks(172.16.0.0 0.0.255.255) that I need to filter out, so that they do not end up in R2 routing table:
on R1 , I have created Route Map , but before even I specify anything in Access-List and make route map match the Access-list . I have found that the Network 172.16.0.0 has already  been filtered out from R2 routing table... I wonder what has filtered it out .



R2(config)#do sh ip route | inc 172.16
R2(config)#

you see there is nothing about 172.16.0.0  in R2
Thanks



R1(config-route-map)#    do sh ip interface br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.12.1    YES NVRAM  up                    up      
FastEthernet0/1            unassigned      YES NVRAM  administratively down down    
FastEthernet1/0            unassigned      YES NVRAM  administratively down down    
FastEthernet1/1            unassigned      YES NVRAM  administratively down down    
Loopback0                  172.16.0.1      YES manual up                    up      
Loopback1                  172.16.2.1      YES manual up                    up      
Loopback2                  172.16.3.1      YES manual up                    up      
R1(config-route-map)#

Open in new window






 
R1(config-route-map)#do sh run
Building configuration...

Current configuration : 1622 bytes
!
! Last configuration change at 20:04:20 UTC Wed Nov 15 2017
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface Loopback0
 ip address 172.16.0.1 255.255.255.0
 !
!
interface Loopback1
 ip address 172.16.2.1 255.255.255.0
 !
!
interface Loopback2
 ip address 172.16.3.1 255.255.255.0
 !
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex auto
 speed auto
 !        
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!         
!
router eigrp 1
 distribute-list route-map FILTER_OUT out 
 network 172.16.0.0
 network 192.168.12.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
ip access-list standard NET_192
!
no cdp log mismatch duplex
!
!
!
!
route-map FILTER_OUT deny 10
!
route-map FILTER_OUT permit 20
!         
!
!
control-plane
 !
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

R1(config-route-map)#

Open in new window

jskfanAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
router eigrp 1

 distribute-list route-map FILTER_OUT out
!
route-map FILTER_OUT deny 10
!
route-map FILTER_OUT permit 20
route-map FILTER_OUT deny 10 <- is equivalent to deny any

If match statement is missing in route-map - that mean match all
Since first you have deny 10 statement -> it will deny any route that matches match criteria, since no match is configured -> all routes will match -> all routes will be filtered in out direction.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jskfanAuthor Commented:
Correct..
0
jskfanAuthor Commented:
Excellent !! Thank you
0
JustInCaseCommented:
You're welcome.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.