How do I resolve this error

Lola Tolorunlogo
Lola Tolorunlogo used Ask the Experts™
on
Parse error: syntax error, unexpected T_CONST in C:\wamp\www\codeigniter\system\core\CodeIgniter.php on line 58
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Fractional CTO
Distinguished Expert 2018
Commented:
Okay. This will be a bit complex.

First, your problem relates to PHP, not Apache, so I've tagged your question as PHP also.

Type type of problem normally occurs after an upgrade, which causes a mismatch between your PHP version + CodeIgniter version.

The upgrade could have been an OS upgrade, a PHP upgrade or a CodeIgniter upgrade.

Regardless, the fix is matching your version of PHP + CodeIgniter.

The CodeIgniter docs are surprisingly sparse, regarding exact PHP version support.

Reading other forums, it appear CI 2.X can use PHP-5.5 + older. CI 3.X requires PHP-5.6 + greater.

There's no mention about specific support for PHP 7.0 or 7.1 or 7.2 so likely you're best option will be to open a ticket with CI support + ask them about this error, related to your PHP version + CI version.
David FavorFractional CTO
Distinguished Expert 2018

Commented:
I've marked my solution as best, since it was the only one + original poster seems to have stopped posting.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial