Incomplete configuration

Hi
I am trying to install OpenMS following the instructions at http://ftp.mi.fu-berlin.de/pub/OpenMS/release-documentation/html/install_linux.html.

I have run the following commands:
sudo apt-get install build-essential cmake autoconf patch libtool automake
    sudo apt-get install qt4-default libqtwebkit-dev
    sudo apt-get install libeigen3-dev libwildmagic-dev \
      libxerces-c-dev libboost-all-dev libsvn-dev libgsl-dev libbz2-dev
    # use from contrib for compatibility: SEQAN ; COINOR; ZLIB ; WILDMAGIC

# Assuming you are in ~/Development
git clone  https://github.com/OpenMS/contrib.git
mkdir contrib-build
cd contrib-build
cmake -DBUILD_TYPE=LIST ../contrib

cmake -DBUILD_TYPE=SEQAN ../contrib
cmake -DBUILD_TYPE=WILDMAGIC ../contrib
cmake -DBUILD_TYPE=EIGEN ../contrib

All these commands work fine, but the next one does not work:
cmake -DBUILD_TYPE=ALL -DNUMBER_OF_JOBS=4 ../contrib

I get the error:-- Configuring incomplete, errors occurred!
See also "/home/gcefalu/Development/contrib-build/CMakeFiles/CMakeOutput.log".

Is it possible that I m missing some linux library?
CMakeOutput.log
sunseAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Rebuild with -DNUMBER_OF_JOBS=1 which outputs build in sequence.

Using multiple jobs scrambles output of many steps, making debugging difficult.

Also the log you posted did not contain the Configuring incomplete message you mention.

So... Rebuild + post all commands + all output + your build log.
0
sunseAuthor Commented:
This time I used cmake -DBUILD_TYPE=ALL -DNUMBER_OF_JOBS=1 ../contrib  and it worked.  Please see attached file.  So what is the difference between 1 and 4?

Thank you for your help
0
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Aha!

You lucked out.

First thing to do, open a bug ticket with OpenMS letting them know about this problem.

The reason this worked, is because -DNUMBER_OF_JOBS=X runs X number of compiles in parallel. For this to work correctly, dependencies must be setup correctly in all the cmake config files. Getting this 100% correct is tough.

For now you have your fix - use -DNUMBER_OF_JOBS=1 when compiling.

Be sure to open a bug ticket with OpenMS, so they can fix their problem.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

sunseAuthor Commented:
Thanks.  I will contact OpenMS and let them know.
0
sunseAuthor Commented:
Hi,


I am getting an error pointing to a bug when I run the command make during Configuring and building OpenMS/TOPP at http://ftp.mi.fu-berlin.de/pub/OpenMS/release-documentation/html/install_linux.html

 Please see below.


c++: internal compiler error: Killed (program cc1plus);Please submit a full bug report,;with preprocessed source if appropriate.;See <file:///usr/share/doc/gcc-6/README.Bugs> for instructions.;src/openms/CMakeFiles/OpenMS.dir/build.make:917: recipe for target 'src/openms/CMakeFiles/OpenMS.dir/source/MATH/STATISTICS/LinearRegression.cpp.o' failed;make[2]: *** [src/openms/CMakeFiles/OpenMS.dir/source/MATH/STATISTICS/LinearRegression.cpp.o] Error 4;CMakeFiles/Makefile2:1106: recipe for target 'src/openms/CMakeFiles/OpenMS.dir/all' failed;make[1]: *** [src/openms/CMakeFiles/OpenMS.dir/all] Error 2;Makefile:138: recipe for target 'all' failed;make: *** [all] Error 2


It is a C++ compiler error.  How could I fix this?
0
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
I'd submit this error to the OpenMS project + ask for assistance.

Likely someone associated with OpenMS dev will now the answer instantly.
0
sunseAuthor Commented:
Hi,

It seems that the software consumes a lot of memory during installation.  I had to increase the memory in my virtual machine to 4GB.  Finally I have decided to install the program in a real ubuntu machine.  Now, I am using Dell's NUC with 16 MG of memory.  I know it has an intel quad processor, but I do not understand much about that.  When I run the command above I can use 4 instead of 1 and it runs well to completion.  I will study more carefully what makes the difference.
0
sunseAuthor Commented:
Now , I have to write a path in the .bashrc file and when I type sudo vi .bashrc I get an empty file.  Is this supposed to be this way and I can just add my path or is there any thing going on?
0
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Marking my solution as best.

Poster seems to have fixed problem + started a new question.
0
sunseAuthor Commented:
The question can be closed.  I do not see a button on the web page to close the question. Thank you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.