This plugin required woocommerce installed - URGENT, site down!

I was doing something with my wordpress site with DIvi builder, and Divi asked that I deactivate my wordpress plugins one by one to see if they were causing a problem.

I deactivated woo-commerce, which is only on one portion of the site, and I get this: This plugin required woocommerce installed.

That's all I see on the home page. Help!  https://techgardens.com/
mel200Asked:
Who is Participating?
 
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Ah... I see... https://techgardens.com/wp-admin emits the same message.

I have to fix problems like this for my WordPress hosting clients every day.

Fastest fix is do this on the command line...

cd /path-to-your-wordpress-install-directory
wp-cli.phar --allow-root plugin activate woocommerce

Open in new window


If you don't have command line access, update this question + I'll give some thought to how to get around this, outside the command line... which will be far more complex.
1
 
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
BTW, Divi is a mess of a theme + their tech support tend to tell people things... like they told you, without understanding the consequences...

So likely good you think through anything Divi support tells you very carefully, before you take action.
1
 
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Glad this helped.

Having wp-cli handy is a serious time saver.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.