SSIS Lookup component "Warning: Cannot retrieve the column code page info from the OLE DB provider"

Hi,

I have a very basic SSIS package which copies records from a SQL database table to an Oracle database table.  Although it executes correctly without error, there is a persistent 'WARNING' icon on the lookup component.  The warning is:

[Lookup [2]] Warning: Cannot retrieve the column code page info from the OLE DB provider.  If the component supports the "DefaultCodePage" property, the code page from that property will be used.  Change the value of the property if the current string code page values are incorrect.  If the component does not support the property, the code page from the component's locale ID will be used.

I have resolved this same warning on the OLE DB source and destination components by setting the property "AlwaysUseDefaultCodePage" to TRUE but the LOOKUP component does not seem to have this property.

My question is:
Is there something I can do to resolve this warning on the LOOKUP component in the data flow or is it ok to ignore it as the package executes successfully?

Thank you for your help! (I am new to SSIS...)  I am developing the package using Visual Studio 2010 Shell

This is a screenshot of the data flow so you can see the warning is on the lookup component:
SSIS Lookup Component Warning screenshot
graandrewsAsked:
Who is Participating?
 
ManjuIT - Project ManagerCommented:
Hi - There should be no consequence of not resolving this warning. The code page is the character set of non-unicode strings. Changing this setting basically tells SSIS to assume that the code page 1252 (default for SQL server). And if you are pulling from 2 sources in the same language, you should be fine. More details here: Link

you can safely ignore it :)
0
 
Pawan KumarDatabase ExpertCommented:
Please follow the steps -

Right-click the OLE DB source or destination object, and then click Show Advanced Editor….
On the Advanced Editor screen, click the Component Properties page.
Set AlwaysUseDefaultCodePage to True.
Click OK.
Clicking OK saves the settings for use with the current OLE DB source or destination object within the SSIS package.

Open in new window


https://msdn.microsoft.com/en-us/library/aa705760(v=bts.10).aspx
0
 
graandrewsAuthor Commented:
Thank you for the response Pawan Kumar :)  I have already done this and set AlwaysUseDefaultCodePage to True on both the OLE DB Source and OLE DB Destination components.  The warning is on the "Lookup" component and it does not have the "AlwaysUseDefaultCodePage" property in the advanced editor/component properties.
0
 
graandrewsAuthor Commented:
Thank you Manju,  I am happy that you confirmed that I can safely ignore the warning.  The package works well, that was my only concern.  Thanks again!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.