• Status: Solved
  • Priority: Low
  • Security: Public
  • Views: 78
  • Last Modified:

Reserverd word in full-free DS

Hi experts,

Trying to create the DS below, but get a compile error on subfield "Select", when I change it in e.g. iSelect it's ok.
I understand that Select is probably a reserved word, but I need this for my WSDL generation.

Dcl-Ds InDs Qualified;       
   Select Char(10);          
   Info Char(10);            
   Dcl-Ds Details;           
      Detail_LENGTH Int(5);  
      Dcl-Ds Detail Dim(10); 
         DetailText Char(25);
         DetailCode Char(10);
      End-Ds;                
   End-Ds;                   
End-Ds;                      

Open in new window


For now I solved it by using a DS specification with D-sepcs.
I can't imagine that I have to use an old-fashioned D-spec line for this type of constructions in full-free.
0
Murphey
Asked:
Murphey
  • 3
1 Solution
 
MurpheyApplication ConsultantAuthor Commented:
Changed "Select"to "iSelect", this is not a solution.

BTW Nested structures give some issues in "IBM Rational Developer for i V9.5" ; prompting will not work .

InDs. + [ctrl][space] will prompt iSelect, Info, Details
InDs.Details + [ctrl][space] will prompt nothing.

Waiting on patch :-)
0
 
MurpheyApplication ConsultantAuthor Commented:
Found it :-)

DCL-DS *N;
     DCL-SUBF select CHAR(10);
     name CHAR(10);
    DCL-SUBF address CHAR(25);
  END-DS;
0
 
MurpheyApplication ConsultantAuthor Commented:
Solved it
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now