Paradox Index Out of Date

Hey guys so I have a big problem. About 20 years ago my partner helped program a software for our business but he is no longer here with us. I have all my company information stored in this program. Yesterday suddenly my computer crashed while paradox was running. But I managed to boot it back up.

When I reopen PARADOX And try to access the directory this shows up

Cannot open LINEITEM.DB.
Index is out of date.
Table C:\GM2\LINEITEM.DB

Now I am completely computer illiterate and have tried to do my own research but it's like you guys are speaking in a different language. So it would really be appreciated if anyone can explain to me how I can fix this in more simple terms. I'm thinking reindex?
Stan LeeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

aikimarkCommented:
does your Paradox environment include TUtility?  That will allow you to rebuild the index.
1
Stan LeeAuthor Commented:
Yes I just checked and I have it. Do you know what it is I need to do with TUtlity?

I really appreciate your help
0
aikimarkCommented:
Launch the application and see if you can figure out how to rebuild the broken index from seeing the UI.  There are some video tutorials that you can find.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Stan LeeAuthor Commented:
What is UI? Is it system info?

So I launched the TUtlity app and there is automatic rebuild button I presume that means rebuild the index. I click it and what it ends up doing I think, is just create a different folder for the directory/table I wanted to rebuild. And I went back on paradox and tried to access the table and same error index out of date occurred.

Any other ideas?
0
Stan LeeAuthor Commented:
So after some more reading I'm thinking perhaps I have an outdated version of TUtility? There is a verify, rebuild, and manual button after I select the directory
1511013080407474780813.jpg
0
aikimarkCommented:
UI = User Interface
GUI = Graphical User Interface
0
aikimarkCommented:
If it created a new index file, you might do the following:
1. back up the index file(s) in the production directory
2. copy replace the index files created by the utility
0
Stan LeeAuthor Commented:
Yup that works!

But the only thing is I lost some of data within that index files. When I replaced the old index files with the newer ones I noticed the file sizes were smaller. It is for my invoices. I have ones from a decade ago. But the recent ones within the last few years are gone.

I still have my the old files copied. Is there a way to manually reindex or repair them myself? I believe the problem is possibly within the header
0
aikimarkCommented:
You're probably going to need to do some data entry.
0
aikimarkCommented:
Depending on your application, you might be able to enter the documents.  Be aware that you will need to pay attention to the dates associated with the documents you re-enter.
0
Geert GOracle dbaCommented:
an index doesn't contain data
rebuilding indexes is a pain which comes with paradox (and dbase)

you might want to ensure you have a very good backup solution
even cd roms fail after a few years.
and start thinking of moving the data to a newer type of database

this will require changes to the program
i'd advise creating a gig for that or finding a local freelancer to look at it
1
Stan LeeAuthor Commented:
Yes I have thought about it in the past but had no idea how to go about it. Will probably give one of you guys a shout. Thanks!

So my invoices show but some of the old files disappeared. Are you suggesting I just manually reenter them?

Also theres one more problem. I try to access my inventory and it also shows that index is out of date. The DB. file associated is also LINEITEM.DB which was the problem with opening up the invoices. They somehow share the same index as what my inventory is associated with.

Rebuilding the index using TUtility partially solved the problem(lost some data) with my invoices but im still unable to access my inventory. Is there another way to repair/rebuild the index more efficiently other than TUtility? Would it have to be manual or is there an automated software? I've come across a bunch but don't know which actually does the job correctly. Or preferably any freeware?

I just want to thank you guys for your help again. Sure sounds like you guys know your stuff.
0
Geert GOracle dbaCommented:
rebuild ...
internally what it does, is list the table and columns the index is put on
for each index: the index is dropped and recreated

there used to be a tool which came with delphi which could do this too: Database Desktop
http://docwiki.embarcadero.com/RADStudio/Berlin/en/Tools_for_Working_with_the_BDE
with these tools you can query the tables without having to use the indexes


you could try these tools on torry:
https://torry.net/pages.php?id=1440
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.