Gmail labels appear on android despite "show in IMAP" is unchecked

I do not want to see the label "Zen Archives" when using email in the Gmail App on my android.  In my Gmail account under Gmail > Settings > Labels, I have un-selected "Show in IMAP". Why does the label continue to appear on my phone? That label does contain nested labels, but the IMAP settings for those labels is also unchecked. IMAP is enabled. I have restarted my phone multiple times.  Please advise.
Picture2.png
kpolacekAsked:
Who is Participating?
 
Jackie ManCommented:
Do not waste your time to do anything.

"In my Gmail account under Gmail > Settings > Labels, I have un-selected "Show in IMAP". Why does the label continue to appear on my phone? "

Why?

gmail app uses a special protocol only Google knows about and it must not be IMAP protocol.

Source: https://www.neowin.net/forum/topic/1245468-android-gmail-app-is-gmail-imap-or-special/
0
 
ITSysTechSenior Systems AdministratorCommented:
Have you tried moving everything out of the label and nested labels then deleting them and than recreating them?  You might also what to call the label a different name when recreating it to insure it does not cause the same issue.
0
 
ITSysTechSenior Systems AdministratorCommented:
inactive for 14 days
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.