• Status: Solved
  • Priority: Medium
  • Security: Private
  • Views: 49
  • Last Modified:

SQL Replication issue - Permission

Dear Experts,

I am following this

https://www.mssqltips.com/sqlservertip/2386/initialize-sql-server-replication-using-a-database-backup/

The issue now is the it seems that a domain admin account does not have the permission to conduct the replication.

We then have this error message when we tried to start the job: "Executed as user "domain account". A required privilege is not held by the client. The step failed"

So in the first and third of the jobs from the SQL Agent Service, we have to change the Run As from [REPL][Domain account][server job] to SQL Server Agent Service Account.

We really have no idea what is the required privilege of the domain account to execute the SQL replication process.
0
Anonymous KH
Asked:
Anonymous KH
1 Solution
 
Pushpakumara MahagamageVPCommented:
Use SQL Server authentication instead of Domain account.

If you need to use Domain account, grant necessary SQL privileges for same domain account at Distributor/Publisher and on Subscriber

https://esha.zendesk.com/hc/en-us/articles/202977089-Granting-Access-to-Additional-Users-with-SQL-Server-Management-Studio-for-Genesis-Food-and-Food-Processor 
https://blog.sqlauthority.com/2008/12/27/sql-server-add-any-user-to-sysadmin-role-add-users-to-system-roles/

Don't use domain admin account as replication agent.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Tackle projects and never again get stuck behind a technical roadblock.
Join Now