We help IT Professionals succeed at work.

Automatic notification email is not coming

Arif Khan
Arif Khan asked
on
I am using exchange 2013 server.  There are two Mailbox server.
Our management has decided to use to SERVICE DESK software for ticketing. I have created new email ID for example, support@xyz.com. So if any user is facing problem he will send email to support@xyz.com then this request will be fetched by Service desk. Once service desk fetch the email, I will assign that case to an engineer so here is my problem......

When I go to assign the ticket, a notification email should go to end user and engineer whom I have assigned the case but this is not happening. If I use gmail.com, then it is working fine.
Comment
Watch Question

Jose Gabriel Ortega CastroCEO Faru Bonon IT /Top Rated Freelancer on Upwork / Photographer
Awarded 2018
Distinguished Expert 2018
Commented:
Check authentication being used for your software.
if you use Gmail (that uses POP or IMAP) goes fine, but those on the exchange are disabled by default.
Maybe you just need to enable them, like this:
https://technet.microsoft.com/en-us/library/bb124489(v=exchg.150).aspx

But 1st make sure that is not a credential issue or an "authentication type" issue.
Arif KhanSystem Administrator

Author

Commented:
Thank you. But to inform you that I already enabled POP/IMAP. Many users use the same from internal as well as external but they did not report any issue. means it is ok. Can you please suggest some other step
Hi,
Try creating an intenal relay connector and add the IP address of your helpdesk server to the allowed relay devices. - see: https://glazenbakje.wordpress.com/2012/12/30/exchange-2013-how-to-configure-an-internal-relay-connector/

Regards,
Leslie
Senior Solutions Architect
Commented:
Hi Arif Khan,

If service desk application is deployed in your internal network then you would just need to connet with your Exchange server by using IP and port 25.

However, if service disk is depoyed in external network then then please refer to given below  details.

1. If you are not using any smart host appliance  and from externaly your Exchange servers are reachable at 25 point (you can check by running command in cmd  telnet    mail.yourprimary -domain.com  25). You would just need to connect your service desk through SMTP authentication using IP or mail.yourprimarydomain.com and use port 25 with disabling SSL.

2. If you have deployed any smart host appliance and MX record of your domain is pointing to smart host appliance then you would need to make relay.
Arif KhanSystem Administrator

Author

Commented:
I is located in internal network. I created a receive connector and assigned role as FRONT END, added Exchange IP in it. But still it is not working.
Muhammad AsifSenior Solutions Architect

Commented:
If it is in internal network then just Use the IP of any Exchange server along with port 25 and do not use any SMTP authentication. Is there any option of SMTP authentication and without SMTP authentication?

If there is an option of to go without SMTP authenticataion then please go with this optin. In this case you would just need to enter the IP of Exchange server and port 25.  It would great of you share the screenshot of configurations in service desk.