Exchange is not connecting with MT service provider

Arif Khan
Arif Khan used Ask the Experts™
on
I have exchange server 2010 and we have set mail relay to logix. Means, our exchange send email to Logix and then logix forward email to repient domain. But today our exchange is not connecting with logix. earlier IP reputation was poor, so I changed the IP of exchange and same NAT in firewall. OWA is working fine using IP and DNS name. Again, I set relay to LOGIX, it  is not connecting with exchange.

451 4.4.0 Primary target IP responded with: "421 4.4.2 connection drop due to socket error. "attemped failover to alternate host but that did not succeed. Either there are no alternate host or delivery failed to alternate host."
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
LBTechSolOperations Director

Commented:
Have you confirmed your new External IP address with Logix, They may need to add it as an accepted address to allow mail in (as they wont be an open relay).
Arif KhanSystem Administrator

Author

Commented:
MTA has given us USER ID and PASSWORD and dns name. So put only host address and user ID and password then it start working. Here we are putting right credentials but no luck.
System Administrator
Commented:
So finally I found the problem. I traced the email, it was coming by my old IP which was blocked due to which Logix was rejecting exchange connection request. Changed the IP, It is working perfect.
Arif KhanSystem Administrator

Author

Commented:
IT FIXED

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial