SBS-2008 won't start well after restore

Hi. It's about a SBS-2008 server. Just before fasing him out we have a problem. The Adaptec 2420sa sata controller is defect. We have a good backup on an usb disk. But, the controller is an old one and is not available anymore, only in other countries, second hand. That takes time to get it.
The server had 3 disks of 500Gb in raid-5. What i did was placing a new 2Tb disk on the sata controller on the mainboard (same controller as the dvd-reader), so a well know controller for this server, started from sbs dvd and repaired the server by restoring from backup usb disk. That took 6 hours without problems but after restarting the server you can see Windows is starting. Then the screen goes black with a mouse pointer (i can move the pointer) and then after about 20-30 seconds the server restarts.
Also in safe mode and safe mode with dos-prompt the server restarts after 20-30 seconds.

When i start the server with the 2420sa in it the bios of the controller says "fatal error: Controller monitor failed. Controller not started." It has the newest firmware but when i try to flash the image again i get "The flash file does not match this controller", but that can be because the controller is not starting, i think. I tried this because i thought may be it gets the controller back alive.

I copied older files from system32\config\regback to system32\config but that didn't help and also renamed system32\winevt\logs to logs-old and the created a new logs folder, but that didn't help also.

Is the server still searching for the Adaptec and can't it therefor not boot correctly? I have used this method of restoring more than ones and it was always succesful. In this case the difference is that the sata controller is another one.

Any help will be appriciated.
Piet WaldaOwnerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davis McCarnOwnerCommented:
That card is on ebay, brand new in the box for $29.00:
https://www.ebay.com/itm/Adaptec-Serial-ATA-II-RAID-2420SA/253180680956?epid=2164334449&hash=item3af2be9afc:g:pN0AAOSwGFpZzanr
Can I ask why you restored the backup to a foreign disk?  If the existing RAID 5 was the boot volume, you will have seriously confused Windoze and I would expect it to blow up on you.
0
Piet WaldaOwnerAuthor Commented:
Hi Davis,

Thanks for the link. I didn't know. But for the raid-5. I don't think that will be al big problem because Windows don't even know there was a raid-5. It is a hardware raid-5. And, Windows is starting, but not far enough.
The only problem might be that there was first a Adaptec driver and now it has to start from sata on the mainboard. I have tried a few registry settings (i could reach the registry offline) for sata settings.

Also i found a 2410sa (the little brother of the 2420sa) but with the old disks on 2410sa Windows crashes also but different. Something about may be there is an virus Windows says. I has to rebuild, it takes 16 hours to do 16%. So it will take a long time.

In the mean time, i tried the 2Tb attached to the Adaptec 2410sa, but there is no operating system then to boot from. I tried the 2Tb disk on the mainboard sata with the Adaptec also in the computer, but then it restarts after the black screen with the mouse pointer.

Is there something i have to do when first starting from Adaptec and now from sata on mainboard? Will Windows still search for Adaptec when booting and is it therefor crashing?

Thanks
0
Davis McCarnOwnerCommented:
The manual:
http://download.adaptec.com/pdfs/installation_guides/SAS_SATAII_RAID_Controller_Installation_and_Users_Guide_00062-01-A.pdf

I would suggest that you use either the BIOS utility or the Storage Manager CD to verify the Adaptec still thinks the array is intact and am a little worried about having upgrading the firmware having caused it to lose the configuration.
https://storage.microsemi.com/en-us/downloads/storage_manager/sm/productid=aar-2420sa&dn=adaptec+serial+ata+ii+raid+2420sa.html
0
CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

Piet WaldaOwnerAuthor Commented:
Hi Davis, as i wrote. The original Adaptec is defect. I didn't update the firmware. I was hoping the controller would function again after installing the same update again, but that didn't work out.
0
Davis McCarnOwnerCommented:
Then you need to buy one from someplace and carefully study how to move the drives to a new controller.
0
Piet WaldaOwnerAuthor Commented:
Ok, it is working again. I installed the 2410sa (not original card, the original was a 2420sa). I made a raid-5 array on it and restored the backup. That was all. It works again.

What was the problem? There were more problems. At first the old controller was defect. When i putted the other 2410sa controller in the server the origninal disks (raid-5) couldn't start Windows because, i think, something went wrong with the data on them when the old controller 2420sa went defect. So Windows crashed while starting.

I restored then to a disk on the mainboard sata. That didn't work because Windows was backupt when the data was on the disks that were attached to the Adaptec card. So when Windows starts it is still looking for data on the Adaptec card and i couldn't find out had to manage it Windows wouldn't do that. All the registry hacks i found didn't help.

I have tried many more things like disabling the antivirus, different sata modes on the mainboard. Looking for boot log files etc. Stange thing was that there was no "safe mode with active directory repair" but may be that came with newer Windows versions.

If anyone knows how to inform Windows not to look to Adaptec but to the mailboard sata.... Just in case i have this problem again somewhere.

Davis, your help didn't get me to the solution, but i was glad you would help me. Thanks.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Piet WaldaOwnerAuthor Commented:
I found the solution myself. Sorry.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.