Exchange 2007 - public folder mail-disabled

In Exchange 2007, there are public folders that are "Mail-enabled" and that I removed the "Mail-enabled" function with the following Powershell command:
Get-PublicFolder -Recurse -resultsize unlimited -Identity "\Secteur Opérations Régionales\Région 02\4210" | Disable-MailPublicFolder
After executing the PowerShell we noticed in the Public Folder Management console that the public folder is now "Mail-disabled":
 
But when I execute the following powershell command:
Get-MailPublicFolder -Filter {EmailAddresses-like '*4210@mern.gouv.qc.ca*'} | Format-List

The public folder has kept these SMTP addresses:
 
How to completely remove all SMTP addresses from this public folder which is "Mail-disabled"?
See the attach file for picture
PublicFolder.docx
dgswinAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Radhakrishnan RSenior Technical LeadCommented:
Hi,

I believe it was a mail enabled public folder? if so, this will leave the smtp address as this would have created as part of email address policy. You need to edit the policy and remove the addresses.

Also, look at Active directory and see if the object present here? if so, remove it (Open AD>View menu>>Advanced features>>You will be able see an OU called 'Microsoft Exchnage system objects". Look for the mail enabled public folder. Remove.

If still doesn't work then Refer this article for forcefully removing secondary addresses https://www.exchangecore.com/blog/powershell-removing-secondary-smtp-addresses-specified-domain/ which may be useful.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
viktor grantExchange ServersCommented:
Hi,

You have correctly disable the public folder...only with the command:

Disable-MailPublicFolder -Identity "\name"

https://technet.microsoft.com/en-us/library/bb123781(v=exchg.80).aspx

If you send an email to the mail public folder, do you receive it or do you have NDR?

Cheers
0
dgswinAuthor Commented:
When I write to the SMTP address, the email goes to the public folder.
0
dgswinAuthor Commented:
Thanks! Deleting the object in Active directory solves the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Powershell

From novice to tech pro — start learning today.