troubleshooting Question

Cannot copy a SQL Express file from a non-bootable machine

Avatar of Thomas Anthony
Thomas AnthonyFlag for United States of America asked on
DatabasesSQL
19 Comments1 Solution116 ViewsLast Modified:
I have a user with a POS system that runs on MS SQL Express. I believe it is V2008. Their machine died and is unbootable but the system hard drive is readable. I am trying to copy the *.dat file their app uses to another machine to get them up again (no they didn't have a backup) but when I try to copy the file it tells me the file is in use. I have tried to take ownership of the file which appears to be successful but I still get the error.
I tried to use NovaStor backup to backup the file but it says it is in use. The hard drive is connected via a USB drive so the SQL program is not running or accessing the file. I assume it is an issue with the file type and SQL Express.
Is there a way to extract this file from the old hard drive and move it to a working machine so I can get their business up and running again?
Thanks so much in advance for your help.
ASKER CERTIFIED SOLUTION
Tom Cieslik
IT Superintendent
Join our community to see this answer!
Unlock 1 Answer and 19 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 19 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros