CISCO 1941 Router Configuration for hotal

Trying to configure a CISCO 1941 router in order to distribute internet services to a hotel guests
the Scenario as following
40 d-link wi-fi access point
access switch d-link
Cisco 1941 with interfaces (gig0/0 gig0/1)
technicolor TG670s with two DSL line connected

and the ISP provide me one ip to access the internet

what is the Configuration required for CISCO 1941
A foudasystem engineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tom CieslikIT EngineerCommented:
Maybe this will not going to be answer for your question but D-Link AP are not good for this job.
It's much better to use Unifi AP for example Unifi AC LR (long distance).
The're manageable from one computer, they share same SSID and KEY so they're working as BRIDGE , so people doesn't need to put different passwords to different AC and you can see how many people are connected, how many data they're using and you have option to block anyone from connecting by put BAN on MAC address , and they're looking very nice on the wall or sealing.

https://www.ubnt.com/unifi/unifi-ap-ac-lr/

I have 11 in my organization and I'm very comfortable and happy.
You can configure many settings or leave all untouched, you can restart remotely any of AP, upgrade firmware, etc. Every time you'll change some settings they're provisioning automatically.
You can create a building map and put devices on it and software will show you coverage

You can create primary network for access to stuff (with more access to other devices like server etc,, and Guest network with access only to internet. Very convenient.
You can setup DHCP on it or use yours.


As for Cisco, all you have to do is open internet traffic to VLAN you'll create and give access to DHCP.

Capture.JPG
Capture.JPG
Capture.JPG
Capture.JPG
0
yo_beeDirector of Information TechnologyCommented:
@tom.

I like your suggestion. I have a similar setup, but using Meraki AP's. I am able to to setup a Guest Network without having to create a vlan.

@A Founde
When you setup a network of AP's you need some central management for all AP's so guest are able move with ease.
0
A foudasystem engineerAuthor Commented:
thank you tom / yo_bee

but the wi-fi in the hotel is open without password and this network for guests only to provide free internet service.

what i need the required configuration for CISCO 1941, like NAT, DHCP, ip protocol to distribute the internet service in local lan
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Tom CieslikIT EngineerCommented:
Ok, so just log on to Cisco and use terminal to configure ISP network address and your LAN (You can use different lan IP, this is just for example)

enable

configure terminal

interface gig X/X  <------Fill in this area for the interface you connected to the ISP

ip address a.a.a.a b.b.b.b    <------------- This will be the IP address and subnet mask your ISP has given you

Also, if you are not using DHCP from your ISP, you will need to create a default route:

enable

configure terminal

ip route 0.0.0.0 0.0.0.0 c.c.c.c      <--------- The c.c.c.c will be the ISP

Now, so you don't have to use static IP addresses anymore for your PC:

enable

confiure terminal

service dhcp

ip dhcp excluded-address 10.10.10.1

ip dhcp pool users

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 8.8.8.8      <------------------ This is a google public DNS server, if you know your ISP's DNS, use that
0
A foudasystem engineerAuthor Commented:
thanks mr tom
Do we need, NAT or RIP protocols on the router?
0
Tom CieslikIT EngineerCommented:
NAT is simplest. RIP you will help only if you going to have another router in your network.
0
A foudasystem engineerAuthor Commented:
i made the mentioned configuration but still no internet at end devices ?!
0
A foudasystem engineerAuthor Commented:
OK, the internet working with the below configuration

ip dhcp pool HOTEL
 network 172.168.0.0 255.255.0.0
 default-router 172.168.0.1
 dns-server c.c.c.c  fill wit the IP provided by ISP
ip dhcp excluded-address 172.168.0.1 172.168.0.100

interface GigabitEthernet0/0
 ip address y.y.y.y m.m.m.m  fill wit the IP provided by ISP
 ip nat outside

interface GigabitEthernet0/1
 ip address 172.168.0.1 255.255.0.0
 ip nat inside

ip nat pool users y.y.y.y y.y.y.y netmask m.m.m.m
ip nat inside source list 1 pool users overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
access-list 1 permit 172.168.0.0 255.255.0.0
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
A foudasystem engineerAuthor Commented:
the system work properly with my solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.