Setup mySQL on Centos 7

Try to setup a new mysql , where I should suppose to  input MySQL new password but it asks for my password instead.  I have tried root password but no hope.

Any idea ?


Open in new window

mysqlInstall.txt
AXISHKAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Manfred BertlManagerCommented:
Why are you doing it with 'sudo' when you are already logged in as root?
0
AXISHKAuthor Commented:
Already fixed the password issue. Local access seem fine.

However, I can access to the mysql through mysql workbench. Any idea ?/

Thx
0
Manfred BertlManagerCommented:
If you can access through workbench, then everything is fine, right? =)
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

David FavorLinux/LXD/WordPress/Hosting SavantCommented:
AXiSHK, I believe you meant to say you can't access mysql through Workbench.

If Workbench is running on a remote IP (non-localhost), then you'll have to create a GRANT for a user to access your MySQL instance.

https://webmasters.stackexchange.com/questions/68233/ubuntu-server-mysql-remote-access-from-mysql-workbench covers how to do this.
0
Prabhin MPEngineer-TechOPSCommented:
Hi
Seems like remote login  is not enabled in mysql for the particular database.
0
AXISHKAuthor Commented:
SQL WorkBench can't connect to the server IP with port 3306...  it seems that it only allow me for local access...

Try to telnet to the mysql server through port 3306, it can't connect. However, local access work prefect...
0
Tomas Helgi JohannssonCommented:
Hi!

Using your local connection to MySQL (mysql command console) issue this command.

 GRANT ALL PRIVILEGES ON *.* TO 'USERNAME'@'%' IDENTIFIED BY 'PASSWORD' WITH GRANT OPTION;

Open in new window

or
GRANT ALL PRIVILEGES ON *.* TO 'USERNAME'@'1.2.3.4' IDENTIFIED BY 'PASSWORD' WITH GRANT OPTION;

Open in new window

where USERNAME is your username and 1.2.3.4 is your remote IP-address. Note that the first grant example puts a wildcard on the IP address so that you can connect to the database from any IP-address.
Then issue
 FLUSH PRIVILEGES;

Open in new window


To see the outcome of grants to your user isssue
SELECT * from information_schema.user_privileges where grantee like "'USERNAME'%";

Open in new window


Regards,
    Tomas Helgi
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AXISHKAuthor Commented:
thx
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.