Lenovo Windows 10 Screen stay black after wakeup

Hi,
I have 4 laptops Lenovo now with Windows 10 and whatever updates I put on them, their screen keep staying black one in a while when they wake up  from sleep.

I use to hold the power button for 10 seconds, until I discover that doing a VNC connection to them and going to Screen Properties was the solution... but what a pain.
What I have discovered is that by plugin  a second screen, in the Monitor Properties, it says "Display only on monitor 2"... as soon as I change that to "Extend" my screen opens-up.

Of course: Lenovo Suport is pure crap... they didn't even tried to diagnose the problem: the 1st line person (which looked more like a phone dispatcher) instantly concluded to "Hardware defect" and wanted to give me an RMA .... for my 4 laptops....  (geez I miss Dell sometimes but I love Lenovo X1 Tablets).

Of course I am not returning this laptop since it clearly looks like a software problem
philjansAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

William MillerIT SpecialistCommented:
Have you made sure your video driver is up to date across the 4 laptops? That would be the first action you'd want to take with something like this.
0
JohnBusiness Consultant (Owner)Commented:
I have a Lenovo X1 with Windows 10 V1709 Build 16299.64 and I use Windows 10 RDP to talk to other machines.

Take one machine, uninstall VNC if on the machine, then update power management, BIOS, Chipset, fingerprint reader (if exists), NIC (wired / wireless) drivers, video and audio drivers.

Set Lenovo Easy Resume to OFF.

Now update Windows 10, restart, and test.

Easy way to update drivers is Lenovo Companion.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
philjansAuthor Commented:
@John: All is up to date.
I don't know what is "Easy Resume": How do I get to it?
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

JohnBusiness Consultant (Owner)Commented:
Start, Companion, Hardware settings (left side), 30-day Standby, turn 30-day Standby, and Easy Resume both OFF. Restart after that.
0
philjansAuthor Commented:
I turned off 30-day Stanby but Easy Resume was already off...
0
JohnBusiness Consultant (Owner)Commented:
My machines (my X1 and a ThinkPad X230 spare) both wake up from Sleep.

Make sure Hibernation is OFF and Lid Close Suspends (Easy Resume may have changed it to "nothing")

Device Manager, System Devices, right click, Update Driver and see if it updates.
0
McKnifeCommented:
You should rule out 3rd party software interference. VNC was mentioned and is indeed a candidate. Completely uninstall it and reboot. Make sure there is no virtual graphics component remaining (years ago, VNC or at least ultraVNC used a virtual graphics device).
Also try to reproduce your problem in safe mode.
0
RaminTechnical AdvisorCommented:
1.Press Windows key + X on the keyboard.
2.Click on Control panel.
3.Type “Troubleshooting” without quotes in the Control panel search box.
4.Click on Troubleshooting and click on View all.
5.Click on Power troubleshooter and follow the on-screen instructions.

Also try to run the “System maintenance troubleshooter” from “Troubleshooting” lists after running “Power Troubleshooter“.

Also turn off “Fast Restart” in the power settings.

More suggestions:
http://www.troublefixers.org/windows/fix-windows-10-wont-wake-up-from-sleep-or-turn-on-issue/166/
0
JohnBusiness Consultant (Owner)Commented:
It does not matter whether Fast Restart is on or off. Works both ways. I have done this.
0
philjansAuthor Commented:
Latest version of TightVNC seems not to be too compatible with Win10
0
JohnBusiness Consultant (Owner)Commented:
@philjans - Thanks and I was happy to help you resolve this.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Lenovo

From novice to tech pro — start learning today.