Response group not routing calls to agents

we have a response group for our marin inbound number, the agents are in a queue that is a formal group. however when trying to sign into the group a few have the following error: "cannot retreive the signin state from the pool. try again later or contact your support team"

others are able to sign in but never receive any calls. when we changed the group to an informal group they still did not receive calls. the same occurred when setting as a attendant group.

our setup consists of 3 FE servers in a pool, one edge server, Always-ON SQL, and WSFC for the file share.

all the agents are inside the network, calls properly route to the hold music but not onwards.

we have tried failing over each server as well as doing a  Reset-CsPoolRegistrarState -QuorumLossRecovery
and -servicereset neither resolved the issue.

at this point i do not see any errors in the event logs on any of the 3 fe servers that would be causing this.
masteritlionAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

masteritlionAuthor Commented:
this is most likely some issue with the database state. however i could not find any instructions on how to rectify this issue.
0
masteritlionAuthor Commented:
In the interest of completion and for my documentation of the solution that worked for me.
what we did was stop-cswindowsservice on all the FE servers and then we ran Install-CsDatabase -LocalDatabases -Clean
so that all the localdatabases would sync up with the central db.

then we restarted the servers and ran the start-cspool command and they all started successfully and response group's started routing correctly again.

a different issue led us to this solution from the following article: https://uctales.blogspot.ca/2014/11/user-is-not-validly-homed-on-target.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.