W10 ocx registration fails

Hello,
in this forum i found the below quoted post which exactly describes my problem. However the soulution given does not help in my case.
In a Foxpro9 installation under W10pro64 I need the DayView.ocx which i copied to System32 and Syswow64.
On one system the manual regsvr32 procedure works on another it does not.
Thanks for help and here the old question:

"In a command prompt I am running this line:  

C:\Windows\System32> regsvr32 C:\Windows\System32\ImageViewer2.OCX

I get the following error:

RegSvr32
The Module "C:\Windows\System32\ImageViewer2.OCX" failed to load.
Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.  
The Specified module could not be found.  

This is a new 64 bit, Win7 laptop.  The OCX file has been transferred from a 64 bit Win 7 system it succesfully installed on.  I am logged in as Administrator and running cmd as Administrator.  I have a VFP app that relies on this OCX to run. "
Jochen WollenhauptAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vadim RappCommented:
0
Jochen WollenhauptAuthor Commented:
I checked but the ocx file does not have this property, have tried different access rights in the property window before. But thanks for the fast reply!!
0
pcelbaCommented:
The OCX folder does not matter but you should use appropriate regsvr32 based on the OCX bit depth, so SysWoW64 for 32 bit OCX and  System32 for 64 bit OCX. You have to use CMD.EXE with elevated rights (Run As Administrator).

The "OCX failed to load" error itself obviously means there is missing C or C++ runtime library in your system. Some OCXes need MSVCR71.DLL, MSVCP71.DLL, MSVCR80.DLL, MSVCR100.DLL etc. Everything depends on the C++ version used for their compilation.

Your FoxPro application also uses DLLs which are not delivered together with operating system but you have to add them to the installation together with VFP Run-time.

So the best approach is to place all the OCXes to application folder together with appropriate C++ DLLs and register them from application folder.

Which DLL is necessary for your OCX could tell the OCX vendor or you may use Dependency walker (http://www.dependencywalker.com/) and investigate this small issue yourself.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Vadim RappCommented:
I would run process monitor while doing regsvr32, looking for anything "not found".
0
Jochen WollenhauptAuthor Commented:
Thanks!!! I tried process monitor and dependency walker and the latter gave out the missing msvbvm50.dll which i installed manually and now it works!! Thank you for the fast help!!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.