exchange 2010

error

= VSS_E_OBJECT_NOT_FOUND
11080 2cb0  11/19 06:36:33 1366218 CsSnapRequestor::DeleteSnapshot() - Error deleting f75100a4-40b2-4456-93bd-5537c3799a2b shadow set - VSS_E_OBJECT_NOT_FOUND
11080 2cb0  11/19 06:36:33 1366218 CsSnapRequestor::BackupComplete() - Call DeleteSnapshot()  [FAILED, throwing CV exception] - Code = 0x80042308, Description =


my incremental back is successful and full back up is failing with below error.
, if database has integrity issue then for truncation logs would the issue and hence incremental backup would be failing,
but incremental is successful.
pramod1Asked:
Who is Participating?
 
BembiCEOCommented:
Yes, as I can see in the documentation, you create two different jobs for incremental and full backup?
And each job has their own configuration. So it may be an option to have a look on the configuration of the two jobs, if there are differences.
Also a full backup may use a different method than an incremental backup, which may affect permissions.

I'm not a Commvault expert, so just some ideas to follow up and issues from other backup software with exchange.

Other ideas to follow up:
a.) The incremental backup and full backup should have enough time between them to avoid the situation, that one job tries to delete the shadow copy while it is in used by the other one...
b.) There has to be enough disk space on the drive where the shadow copy is created, full backup needs more space than incremental,  
c.) Have a look here, where similar VSS problems are discussed....
https://forum.commvault.com/forums/35278/ShowThread.aspx
d.) Pointing in a similar direction:
http://documentation.commvault.com/commvault/v10/article?p=products/windows/backup_troubleshooting.htm#Backup_Failures_on_Windows_2008__Windows_2008_R2_OR_Windows_7
See here WFS0019: VSS errors
At least there are some log files which may help...

Questions:
Have you every tried to recreate the backup job?
Did it ever worked before, or it this a new setup?
0
 
BembiCEOCommented:
Possibly there are orphaned shadow copies and something is corrupt...

Have you tried to delete the shadow copies?  
File explorer - properties on a drive - Shadow copies....
There you can delete and disable the shadow copies....
After a restart of the Volume Shadow Copy service,, they should have zero size...

You can then have a look into device manager - Storage volume shadow copies (show hidden devices) and they should be empty...
If you see greyed out items left over (all others should be away), you have orphaned items. You can now delete all of them in device manager manually or use the tool DevNodeClean (an earlier tool from Microsoft - but possibly not available anymore....

Orphaned items need not necessarily create a problem but can be an issue...

After all Shadow copies are away, you may enable the shadow copies again (as set before) and see, if the error persists...
0
 
pramod1Author Commented:
but on server shadow copies are not configured ?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
BembiCEOCommented:
If the shadow copies are disabled, you should not see any shadow copies in the device manager.
Check the device manager and make sure, you see hidden devices (grayed out items)...
To avoid left over orphaned items.

If VSS is disabled, this may also be the reason. It depends, how you backup your exchange... Some software rely on the Microsoft VSS, others have their own agents and writers...
Also possible that you have a permission problem, as I can see...
CsSnapRequestor::BackupComplete() - Call DeleteSnapshot()  [FAILED....


You can also use
vssadmin list shadows
to see the shadow copies..... (you may have a look if you find the GUID from above...)
If you can find the GUID, the backup system possibly has read permissions, but is not able to delete the Shadow copy...

or

vssadmin list writers
to see all shadow copy volume writers...
Do you see an "Microsoft Exchange Writer" there?
Any writers with Error (line Last error)?
0
 
pramod1Author Commented:
no there are no errors with writers.coomvault is using microsft vss, incremental is successful but full back up is failing with regard to above error I posted
0
 
BembiCEOCommented:
So you use an Exchange Server Agent from Commvault?
If yes, does this agent have its own service?
Is the service running under a domain account?
Has the account the appropriate permissions?

See
http://documentation.commvault.com/commvault/v10/article?p=products/exchange_database/deployment.htm

Stated here: Backup Operator & Local Admin
And possibly - dependent from the backup method -- Exchange Permissions?
0
 
pramod1Author Commented:
but incremental is running fine
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.