vcenter applicance error failed to connect to server

tjguy
tjguy used Ask the Experts™
on
Have an issue with Vcenter on the server console, after I rebooted, I get a login instead of the Vcenter screen.  I login and it says Failed to connect to service. It then list the few helps commands and the ability to go to shell. This has no effect on the Watchlist app on my phone, or logging into vcenter with a browser.

thoughts or something to try?

thanks
VCENTER_65_ERROR.JPG
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017
Commented:
How long have you waited for the services to start ?

You may want to consider a re-installation, if you do not have a complex environment, it can sometimes be much quicker to Re-Install a new VCSA 6.5, then try and troubleshoot a failed instance.
tjguyNetwork Administrator

Author

Commented:
I waited 8-10 minutes, simple environment, So delete the VM or just re-install on top of what's there?  a pain for sure but if it's less painful then trying to chase issues I guess I can live with it.

thanks
VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017
Commented:
8-10 minutes, is too short, some configurations, depending upon storage, can take 30 minutes.

This issue can sometimes be a known bug, and if you look through the logs, you can see the error.

BUT, it is much easier to delete the existing VCSA 6.5, and install the latest version.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Ajay ChananaMCSE-2003/08|RHCSA| VCP5/6 |vExpert2018
Distinguished Expert 2017
Commented:
If you have not made any changes usually the VCSA appliance get our of service due to log directory full.

Could you please run the below command  and see if disk is full.


df -h

if yes - clear the log directory.

You may also increase the disk space after that.

follow below kb.
https://kb.vmware.com/kb/2126276
tjguyNetwork Administrator

Author

Commented:
doesn't look like the disks are full. vCenter is working through the web portal, able to view all the VM's edit and etc. not enough exposure to this vCenter prduct to figure out what the issue is. could it had an auto update that failed?  I can also use vSphere client, but it alerts me to the fact that vCenter is being used. what issues if I just let it run the way it is?
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017
Commented:
there is a bug with a duplicate key in the database which causes this issue, if you want to dig through the logs, it could be this!
tjguyNetwork Administrator

Author

Commented:
Andrew Hancock, what am I looking for in the log, something with the word 'duplicate key' ? is there a patch for it, or should I just reinstall like you were saying?
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017
Commented:
Later versions of VCSA have the bug fixed.

Or you can fiddle with your Db and remove the duplicate key,

But as there is now a published fix by implementing the correct fixed version it does not make any sense to deploy a bugged version!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial