Autodiscover issues with Exchange 2010

Tim
Tim used Ask the Experts™
on
We have an exchange 2010 server that we recently migrated to and it seems to be working correctly. I can get to my OWA page from outside the network and when I try https://mail.domainname.com/autodiscover/autodiscover.xml it takes me to my OWA login page however it changes the url to include owa in the path e.g. https://mail.domainname.com/owa/autodiscover/autodiscover.xml. When I try to configure Outlook 2016 to connect to our Exchange server it fails and when I run Microsoft Remote Connectivity analyzer it also says that autodiscover fails. One of the tests removes mail from the URL and just uses https://domainname.com:443/autodiscover/autodiscover.xml but that is never going to work since our domain name points to a third party ecommerce site we have set up and is not on our domain.

How can I resolve this. I went to my doamin registrar and looked at how the autodiscover records were set and I have a a CNAME record pointing to our mail server e.g. mail.domainname.com so I don't see how it is pointing to our ecommerce website and not our mail website.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Network Security Engineer
Distinguished Expert 2018
Commented:
You need two A records

A host mail
A host Autodiscover

Did you have those in place?
About microsoft exchange connectivity, he looks for any name that you have configured in your host like
https://domainname.com:443/autodiscover/autodiscover.xml
https://mail.domainname.com:443/autodiscover/autodiscover.xml --Bu this is the one that needs to pick up followed by the autodicover record.

I hope this help,
Tom CieslikIT Engineer
Distinguished Expert 2017
Commented:
I don't know who is your registrant but in Network Solutions thee is opion to forward CNAME to other host

 
 Capture.JPG
Jose Gabriel Ortega CastroTop Rated Freelancer on MS Technologies
Awarded 2018
Distinguished Expert 2018
Commented:
The autodiscover process goes in 4 stages
First: Domain.com/autodiscover/autodiscover.xml
if it's not found
Second: autodiscover.domain.com/autodiscover/autodiscover.xml
if not found
third: would try HTTP (generally for o365)
if it's not found
Fourth:  SRV DNS.

Check internals and externals DNS, it's a DNS issue.
Here's a script: use it with the option -Get
https://gallery.technet.microsoft.com/office/Script-to-configure-the-5a58558b
You will get all the internal entry points

Use it with the option set to set all the internals and externals (-set -urlpath "https://mail.yourdomain.com")

In public DNS you need to have a "A" record to the public ip of your Exchange Server (or firewall if exists), need to open port 443 in the firewall and do the forwarding to the server internally).
And create a CNAME to autodiscover.domain.com
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

autodiscover.domain.com can be either A or CNAME.
The important part is to make sure that in addition to the traditional mail.domain.com, or whatever name you want to use, on SSL certificate, it should also include autodiscover.domain.com
In short you must have two FQDNs on the cert deployed on Exchange:
mail.domain.com
autodiscover.domain.com
Tom CieslikIT Engineer
Distinguished Expert 2017

Commented:
Don't create CNAME, remove it.
Just create A record pointed to your emailserver.yourdomain.com and autodiscover.yourdomain.com and use this address in TXT record.
Also you must have certificate for autodiscover.yourdomain.com to be able set outlook anywhere and activesynch.

On your server you must activate autodiscover on your email server

Get-ClientAccessServer | Set-ClientAccessServer –AutoDiscoverServiceInternalUri https://autodiscover.company.com/autodiscover/autodiscover.xml

Open in new window


and add autodiscover.yourdomain.com on port 443 in Bindings in you IIS and bind it to your certificate
Internally there's no need to create autodiscover.domain.com as the clients use SCP, therefore Set-ClienAccessServer can point directly to the name of the server as appears in the certificate.
As well, there's no need to add autodiscover in IIS.
TimSr. System Admin

Author

Commented:
I am confused about the TXT record. When I look online about this there are many examples however I don't know which one I should use. BTW our registrar is Network Solutions. When looking at how to create an SPF record there are many mechanisms I can use. Which one is better? Should I use multiples. And when it is asking for the host name am I using Autodiscover or Mail or both?
Tom CieslikIT Engineer
Distinguished Expert 2017
Commented:
This is an example

v=spf1 ip4:10.10.10.10 a:emailserver.comain.com mx:domain.com ptr ~all
TimSr. System Admin

Author

Commented:
And what should I use as the host? Mail or Autodiscover?
If you asking for the SPF record - usually hostname of the server is being used. Not autodiscover.
Hey Tim,

This AutoDiscover issue needs very clean and clear steps to be resolved. So, be careful while performing the steps related to this. There is a following informative article from Microsoft, which has helped my clients in the similar issue, go through it to resolve your problem:
https://blogs.technet.microsoft.com/exchdxb/2012/05/10/troublshooting-autodiscover-exchange-20072010/

Feel free to ask for further queries.

Best Regards,
Jessica
All the requested information provided

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial