active sync doesnt work

my current setup has exchange 2003 and exchange 2010 in co existence. My active sync doesnt work.

The error is
Attempting the FolderSync command on the Exchange ActiveSync session.
       The test of the FolderSync command failed.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       
Exchange ActiveSync returned an HTTP 500 response (Internal Server Error).
HTTP Response Headers:
Pragma: no-cache
MS-Server-ActiveSync: 6.5.7638.1
Content-Length: 56
Content-Type: text/html
Date: Thu, 30 Nov 2017 04:10:45 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
Elapsed Time: 1050 ms.

I have tried the following
https://technet.microsoft.com/en-us/library/620c5ce8-3595-4658-9a7a-ec76c10e4a69.aspx

https://support.microsoft.com/en-us/help/330463/how-to-troubleshoot-server-activesync-http-error-codes

Requesting for steps to be taken next
Member_2_6474242Senior Systems AdministratorAsked:
Who is Participating?
 
Jose Gabriel Ortega CConnect With a Mentor CEO J0rt3g4 Consulting ServicesCommented:
Ok.
1st Go to "https://yourdomain.com/ECP"
then go to Server/OutlookAnywhere and make sure that you have the public IP (externally).

If it's there, do the test here:
https://testconnectivity.microsoft.com/

if you have doubts about how are your server's URL, try this script with the "-get" option.
https://gallery.technet.microsoft.com/office/Script-to-configure-the-5a58558b
0
 
Member_2_6474242Senior Systems AdministratorAuthor Commented:
thanks this worked like a charm
1
 
Jose Gabriel Ortega CCEO J0rt3g4 Consulting ServicesCommented:
Glad to help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.