• Status: Solved
  • Priority: Low
  • Security: Public
  • Views: 42
  • Last Modified:

Unable to Map a Network Drive

Hello Experts,

I have a Windows 2008 Server configured as domain control.

It has two ip addressess, 192.168.1.25 and 10.1.30.140.

I can map a network drive to 192.168.1.25,  but I can't map a network drive to 10.1.30.140.

I'm certain it's a simple problem, but I can't figure out why I can't map a drive to 10.1.30.140.

Any thoughts will be greatly appreciated.

Cheers
0
Member_2_7966113
Asked:
Member_2_7966113
  • 12
  • 10
  • 2
  • +1
1 Solution
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
You have a multi-homed DC.  That's one problem.

Check your firewall settings.

What errors are given by the client(s)?  Are there errors in the event log?  Why is the machine multi-homed?
0
 
Member_2_7966113Author Commented:
Hi Lee,

As you can see from the image I can map a drive to 192.168.1.25 but I can't map a drive to 10.1.30.140
access
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Do you want 10.1.30.140 as the main IP to map your drive ? or the 192 address ?
what is the reason for having 2 IP addresses ?
I think you may need to change the network connection nic binding order.

https://technet.microsoft.com/en-us/library/cc732472(v=ws.10).aspx
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Member_2_7966113Author Commented:
Hi Zaheer,

Yes, I would like the 10.1.30.140 as the main ip to map to my drive.

The address 192.168.1.25 is just used to connect to the Server via RDP.

Cheers
0
 
Member_2_7966113Author Commented:
Hi Zaheer,

I have placed Local Connetion 2 - ip address 10.1.30.140 at the top, but still no luck. Do I need to reboot server?
access
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Yes please restart.
0
 
Member_2_7966113Author Commented:
Restarted, but no luck :-(
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
ok sorry I missed that this is a DC. Which ip address was the first one to setup when you first joined it to the domain ?
What happens when you try hostname ?
0
 
Member_2_7966113Author Commented:
When I ping the host name n30-dc I get the response 10.1.30.140.

Which makes it even more puzzling why I can't map to 10.1.30.140
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Is the windows firewall on ?
0
 
Member_2_7966113Author Commented:
Windows firewall is turned off
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
what happens if you try and map via \\hostname\ then ?
was the share created on which IP address ? when both ip addresses were configured.
0
 
Member_2_7966113Author Commented:
I get same result as when I map IP address 10.1.30.140 - unable to map
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
can you map the drive on the domain controller itself ?
Can you try to do ipconfig /flushdns on client and test.
0
 
Member_2_7966113Author Commented:
Yes, I can map the drive on the controller itself - which makes this problem even more strange
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
ok another test can you enable disable the network cards, as in disable the 192.168 nic and see if that works?
0
 
Member_2_7966113Author Commented:
Zacheer

I tried disabling 192.168.1.25 before coming to EE, but no luck.

Interestingly, I can ping 10.1.30.140 and when I do nslookup I see 10.1.30.140
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
ok just had another thought under TCP/IP  setting DNS tab do not allow 192.168 address to register to DNS.

What was the primary IP of the DC when you added it as a domain controller ?
0
 
arnoldCommented:
Look on the server whether 445 is listened to on the 10 IP.

Multi-homed is not your only issue, the two are on two separate network means the server has two default gateways?

It seems that the error is a result of the response coming from the 192 IP because it has a higher preference, lower metric value if you check netstat -rn on the server.

If you capture the response to ping, you might see it coming from the 192.168 ip.
1
 
Member_2_7966113Author Commented:
Do not allow 192.168 address to register to DNS.

How do I do that?
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
0
 
Member_2_7966113Author Commented:
That did it. Thanks
0
 
Zaheer IqbalTechnical Assurance & ImplementationCommented:
What was the fix ?
0
 
Member_2_7966113Author Commented:
My apologies,

Zaheer provided the correct answer with the following link:


https://support.microsoft.com/en-us/help/2023004/steps-to-avoid-registering-unwanted-nic-s-in-dns-on-a-mulithomed-domain

Thanks Zaheer
0
 
arnoldCommented:
Report your question, and request to have it reopened.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 12
  • 10
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now