php on AIX

I have installed php 7.0.21-1 on an AIX 7100-3 system. The php executable is in /opt/freeware/bin. LIBPATH is set to
 /usr/lib:/opt/freeware/lib:.

When I try to run php I get the following error:

exec(): 0509-036 Cannot load program php because of the following errors:
rtld: 0712-001 Symbol xmlOutputBufferGetContent was referenced from module php(), but a runtime definition
      of the symbol was not found.
rtld: 0712-001 Symbol xmlOutputBufferGetSize was referenced from module php(), but a runtime definition
      of the symbol was not found.

I have not been able to resolve this error.

Does anyone have any suggestiions?
LVL 20
carlmdAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

carlmdAuthor Commented:
Did you post to the wrong question?
0
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Whew... AIX...

As I recall, from 2005ish when I last worked on AIX, dump -H provides similar output to ldd.

Using LIBPATH will work so long as your linker (xlc or other toolchain) generates correct rpath directives.

I use to build gcc + perl + many GNU tools on AIX. I'm pretty sure I used the system linker, so likely there's some incantation which generates rpath directives.

Use dump -H on your final php executable to ensure all's well.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Julian HansenCommented:
Did you post to the wrong question?
I did - and I am very sorry but not as confused as I was an hour ago when I went to the actual question and could not find my post.
0
carlmdAuthor Commented:
Not really a lot of help but at least you tried. Only answer, so you get the points!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
AIX

From novice to tech pro — start learning today.