long left click turns into right click

When I make a long left click, a white circle appears on the screen and the context menu appears when I release.
What a clever way to fake a right click if you can't make a right click.
And how annoying it is when you don't want it!
Can anyone please tell me how to turn it off?
Knud FjeldstedManagerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
That is the touchscreen behaviour. Are you running W10 in Tablet Mode (start menu and applications always using the full screen)?
0
RaminTechnical AdvisorCommented:
Please try with another USB mouse and let us know the result.
0
Knud FjeldstedManagerAuthor Commented:
I am using a Wacom pen tablet. The stupid win 10 thinks I have a touch screen. How can I correct it?
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
http://www.thewindowsclub.com/disable-touch-screen-windows-10 describes that all you need to do is go into Device Manager and disable the Human Interface Device (HID) driver for the touchpad.
1
RaminTechnical AdvisorCommented:
If above suggestion didn't help then try below steps:

Open control panel >> in search box type Pen and Touch  Choose Press and hold and click Settings.  Uncheck  Enable press and hold for right-clicking.

More detail:
https://www.isunshare.com/windows-10/disable-or-enable-press-and-hold-for-right-clicking-in-win-10.html

1.png
1
Knud FjeldstedManagerAuthor Commented:
Qlemo: "Are you running W10 in Tablet Mode? NO
Ramin: "Please try with another USB mouse and let us know the result. GOT NO MOUSE. ANOTHER WACOM: SAME THING
Qlemo: " go into Device Manager and disable the Human Interface Device (HID) driver for the touchpad. DONE. HAD NO EFFECT
Ramin:  "Uncheck  Enable press and hold for right-clicking."  DONE. HAD NO EFFECT.

It looks to me to be a settings problem somewhere - but I can't figure out where.
Also: when I left click and pull acroos a text to highligt it, "the opposite" happens: the marker disappears during the pull, and nothing is highligted. That doesn't make sense to me at all. (all of this: only in Chrome).
0
RaminTechnical AdvisorCommented:
Thanks for your feedback.  please follow below steps to disable it from Windows registry.


1.  Press the Windows key + R together to open the Run box. Type regedit and press Enter.

2.  When the Registry Editor opens, navigate to the following location:
HKEY_CURRENT_USER\Software\Microsoft\Wisp \Pen\SysEventParameters/HoldMode

Double-click the TouchMode_hold on the RIGHT PANE, and change its value data from 1  to 3 (off).

3.  Close Registry Editor and reboot your PC for the changes to take effect.


                                                                      * * * * *

If the above registry editing didn't fix the issue try this one.

1.  Press the Windows key + R together to open the Run box. Type regedit and press Enter.

 2.  When the Registry Editor opens, navigate to the following location:

HKEY_CURRENT_USER\Software\Microsoft\Wisp\Touch

 If you do not have this key, then just create it.

 3.  Double-click the 32-bit DWORD value named TouchMode_hold on the right pane, and change its value data to turn on or off the “press and hold for right-clicking” feature for your touch screen. 1: turn on; 0: turn off.

 4.  Close Registry Editor and reboot your computer for the changes to take effect.

 If you also want to turn on / off the press and hold for right-clicking feature for a touch pen, open Registry Editor and navigate to: HKEY_CURRENT_USER\Software\Microsoft\Wisp\Pen\SysEventParameters, and then change the HoldMode value (1: turn on /  3: turn off).

Registry method (method 2) Source.
https://www.top-password.com/blog/turn-on-off-press-and-hold-for-right-clicking-in-windows-10/
0
Knud FjeldstedManagerAuthor Commented:
HKEY_CURRENT_USER\Software\Microsoft\Wisp \Pen\SysEventParameters/HoldMode
>>>HoldMode was not a folder but a value, and it was already 3
Double-click the TouchMode_hold on the RIGHT PANE, and change its value data from 1  to 3 (off).
>>>Defined a TouchMode_hold in folder SysEventParameters and gave it the value 3
Done.
* * * * *
If the above registry editing didn't fix the issue try this one.
1.  Press the Windows key + R together to open the Run box. Type regedit and press Enter.
 2.  When the Registry Editor opens, navigate to the following location:
HKEY_CURRENT_USER\Software\Microsoft\Wisp\Touch
 If you do not have this key, then just create it.
 3.  Double-click the 32-bit DWORD value named TouchMode_hold on the right pane, and change its value data to turn on or off the “press and hold for right-clicking” feature for your touch screen. 1: turn on; 0: turn off.
 4.  Close Registry Editor and reboot your computer for the changes to take effect.
 If you also want to turn on / off the press and hold for right-clicking feature for a touch pen, open Registry Editor and navigate to: HKEY_CURRENT_USER\Software\Microsoft\Wisp\Pen\SysEventParameters, and then change the HoldMode value (1: turn on /  3: turn off).
Done
* * * * *
Thank you, Ramin!
This took care of most of the strange behavior, but not all. The most strange is still here:
When I try to mark a string of words by left-click-draw, the marker disappears while left mouse button is down and nothing is marked. UNLESS (!!!) I first double-click in an open Word document and then go to the chrome window; then the mark-up works once.
Same thing done vertically just scrolls the document. UNLESS (!!!) I first double-click in an open Word document and then go to the chrome window; then the mark-up works once.
My Wacom pen tablet is correctly configured in its driver I the control panel. One button is right click, the other is double click.
Any clue?
ONE MORE INFO:
If I place the cursor in a text (still in Chrome), keep shift key down and use right-arrow-key, the text gets marked up as I want, In this weird problem one gets happy if anything works...
0
RaminTechnical AdvisorCommented:
As a workaround for that issue,  Disable 'Use Hardware acceleration in Chrome settings.

Chrome >> Settings >> Advanced >> System. In the System section, uncheck the box next to Use hardware acceleration when available and restart Google Chrome.
0
Knud FjeldstedManagerAuthor Commented:
@Ramin: Sorry - no effect.
0
RaminTechnical AdvisorCommented:
Go to Control Panel >  Pen and Touch > Flicks and  disable Use flicks to perform common actions. (if there is such option).
0
Knud FjeldstedManagerAuthor Commented:
Thanx, but no change
0
RaminTechnical AdvisorCommented:
Please type the below command in Chrome address bar, hit the enter and let it to update then restart chrome and test.
chrome://settings/help
0
Knud FjeldstedManagerAuthor Commented:
Thanx - I'll continue tomorrow - it's late night here now.
0
Knud FjeldstedManagerAuthor Commented:
Thanx - chrome://settings/help  gave no change.
0
Knud FjeldstedManagerAuthor Commented:
This must be the clue
I don't know the correct name for this blue thing popping up all the time. If I knew that, I could google it.
Windows or Chrome must think that I am having a touch-screen. But I don't. I have a Wacom pen & tablet. And I want to continue using it as a refined mouse and not acting as a fat finger on a touch screen.
0
RaminTechnical AdvisorCommented:
Go into your Wacom Tablet Properties > pen > mapping and uncheck "Use Windows Link" and test.

Or create a Restore point,  uninstall Chrome, Restart your Tablet, install chrome and test.

Useful link:
http://community.wacom.com/inspiration/blog/2015/january/5-things-to-know-to-get-you-started-with-your-new-tablet
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Knud FjeldstedManagerAuthor Commented:
Thanx!
Windows Ink is already unchecked.
The other one I shall try when I get home. (Deep down in my memory I feel I have seen that advice before. I think it is good!)
Thanx again.
Knud
1
Knud FjeldstedManagerAuthor Commented:
Unbelievable, Ramin! Literally unbelievable, but nevertheless true.
Such a simple solution to such a tricky problem!
Thank you Ramin - and thank you Qlemo - it might be the combination of all the solutions that finally broke the camel's back.
At any rate: I got my old Chrome back.
Happy holiday for all of you1
Knud
1
Knud FjeldstedManagerAuthor Commented:
Thanxalot!
1
RaminTechnical AdvisorCommented:
You're very welcome.
I'm glad we could help.
Happy Holiday.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.