I can access intranet and internet but W10 tells me I'm not connected to a network??

Windows 10 also tells me that my current network profile is 'guest or public'!?

a. what has caused this?
b. how can I activate the 'domain' option again?

Thanks!
XeronimoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zaheer IqbalTechnical Assurance & ImplementationCommented:
Hi

There is a hotfix available for this issue please download.

https://support.microsoft.com/en-us/help/2524478/the-network-location-profile-changes-from-domain-to-public-in-windows

Are you connected to wireless network as well as a cable connected network ?
0
XeronimoAuthor Commented:
I'm connected via cable. Gonna try your fix!
0
XeronimoAuthor Commented:
Your fix is for Windows 7 though? I'm on Windows 10 ..
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

XeronimoAuthor Commented:
The problem is exactly as described on that hotfix page though!
0
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Apologies missed the OS bit ;)
0
Zaheer IqbalTechnical Assurance & ImplementationCommented:
What has changed ? Was it working ok.
Are you using a fixed IP address or are you using DHCP ?
0
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Add your domain name to the dns suffix option under your tcpip advanced adapter settings/properties.

Disable and re-enable your LAN adapter
0
XeronimoAuthor Commented:
I'm using DHCP. And I can access both the Internet and our local network (using the server names, NOT by browsing!).

What changed is that I had installed VirtualBox (which did something to the network connections/cards) and later uninstalled it again. Problems seem to have started there, but not sure ... on the other hand, other Windows 10 users here seem to experience the same problem, so maybe not related to VirtualBox after all ... could be McAfee maybe? Have to check in with a superior ...
0
XeronimoAuthor Commented:
Domain name had already been added ...
0
Zaheer IqbalTechnical Assurance & ImplementationCommented:
Yes what you need to focus on is what has changed, any changes in DNS?
Disable Mcafee and restart to see if that fixes your issues.

Can you share your ipconfig /all ?
Is your default gateway correct ?
0
McKnifeCommented:
Please read https://blogs.technet.microsoft.com/networking/2010/09/08/network-location-awareness-nla-and-how-it-relates-to-windows-firewall-profiles/ to understand why and when windows decides to select a domain firewall profile.
0
JohnBusiness Consultant (Owner)Commented:
The only time I have seen this (Connected but Icon says No) is the antirust installed. Uninstall your antivirus temporarily and test. Please let us know.
0
XeronimoAuthor Commented:
Zaheer: the ipconfig/ all output is fine, dns suffix is shown correctly
0
XeronimoAuthor Commented:
John: what do you mean with antirust? I'll try to uninstall mcAfee then in order to test it ...
0
JohnBusiness Consultant (Owner)Commented:
I meant antivirus  (typo).  Let us know after you remove McAfee whether anything changed.
0
XeronimoAuthor Commented:
McKnife: I see only 3 options in my GP Editor under 'network list manager policies' (the domain name is missing) .. I guess that's part of the problem?
0
JohnBusiness Consultant (Owner)Commented:
Yes. Try without McAfee and please let us know
0
McKnifeCommented:
"McKnife: I see only 3 options in my GP Editor" - your editor cannot show you the 4th option if it does not determine that it's connected to a domain. The GPO is not there to fix that. I linked the article to give you an overview about the components that play a role.
Normally (own experience), this will only happen if the 1st and 2nd DNS server (the DCs) are not reachable or if the 1st and 2nd DNS entries are set to something different than your DCs' IP addresses. You can check that. You said "ipconfig /all... dns suffix is ok" - that does not matter here, what about the DNS IPs?
1
XeronimoAuthor Commented:
McKnife: DNS IPs are ok too, I can ping both and names do resolve
0
XeronimoAuthor Commented:
John: I've uninstalled McAfee, same problem ... W10 tells me I'm not connected to any networks. Yet I can access my local network (but not browse it) and also the Internet ... It really seems to be this problem but there's no hotfix for W10? https://support.microsoft.com/en-us/help/2524478/the-network-location-profile-changes-from-domain-to-public-in-windows
0
XeronimoAuthor Commented:
And so the main problem is indeed that my PC is connected to (my local network) as 'guest or public network' instead of 'domain network' ... and I seem unable to change that :/
0
McKnifeCommented:
I have sometimes corrected this buggy behavior by simply changing the IP.
Example: client IP was 192.168.0.100, changed it to 192.168.0.101 - bingo, works at once, domain connection detected in a few seconds.
0
XeronimoAuthor Commented:
Ok, so I have hit that 'network reset' button in the settings and now everything works again fine!
0
XeronimoAuthor Commented:
pushing this 'reset now' button made everything work again normally!

ss
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Zaheer IqbalTechnical Assurance & ImplementationCommented:
you suggested other users also have the same issue ?
0
McKnifeCommented:
Thanks for sharing. Yes, virtual box can ruin network settings. But honestly, sometimes you don't do anything else but reboot and this problem is seen. As I told you, I simply change the IP and then (now for the "big" step) change it back to what it was and it works. Any windows component has its bugs from time to time.
0
XeronimoAuthor Commented:
Zaheer: yes, it seems so. will check with them again. I'll try the 'reset now' button there too.

McKnife: yes, might have been VirtualBox in my case. it started acting weird once I uninstalled it.
0
XeronimoAuthor Commented:
because it's the actual solution
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.