Exchange-DAG passive NOD

Environment:
1 DAG
2 DAG members-Server1 and Server2
All databases are active on Server1
Server2 is passive node
If I run
Test-MAPIConnectivity -Server Server1
Everything went fine
But if I run on passive node error appear
Test-MAPIConnectivity -Server Server2

3.png
Is this output  normal on passive node ?

Exchange server looks good.No error in logs but SCOM has raised alert:

"Transaction failures occurred during MAPI connectivity testing."
LVL 1
Andy MladAsked:
Who is Participating?
 
Andy MladAuthor Commented:
Solution:

"It’s recommended to check that if the homeMDB attribute is empty on the offending Microsoft System Attendant object in ADSI. If yes, just simply copy and pasted the value from the System Attandant Object on the other DAG server and restart the System Attendant service on the affected server, then check the results."
0
 
MAS (MVE)EE Solution GuideCommented:
Hi Andy,
You have to use IncludePassive to test in a passive server.Without the IncludePassive parameter, the cmdlet tests MAPI connectivity from active database copies only.
https://technet.microsoft.com/en-us/library/bb123681(v=exchg.160).aspx
1
 
Andy MladAuthor Commented:
Hi,

it seems that -IncludePassive parametar is available only in Exchange 2016.
I have Exchange 2010 :-(

"This parameter is available only in on-premises Exchange 2016.
Without the IncludePassive parameter, the cmdlet tests MAPI connectivity from active database copies only. Using the IncludePassive parameter, you can have the cmdlet test MAPI connectivity from all active and passive database copies."
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
MAS (MVE)EE Solution GuideCommented:
Hi Andy,
AFAIK IncludePassive option only available from Exchange2013 onwards. In Exchange 2010 you can only test active server.
You can test the servers by the script by Paul. Download the script and run command
Test-MailboxServer.ps1

Open in new window

exchange-2010-test-mailboxserver-hea.jpghttps://practical365.com/exchange-server/powershell-script-exchange-server-health-check-report/
0
 
Andy MladAuthor Commented:
Hi,

Test-ExchangeServerHealth script by Paul Cunningham is scheduled to run every day and so far no error

4.png
Logs on server seems fine,but SCOM raised alert and maybe it is false alarm but I need to be sure before override alert.
It would be great If someone have Ex 2010 DAG to test Test-MAPIConnectivity -Server Server2  on passive DAG NOD :-) :-)

SCOM alert :
 Transaction failures occurred during MAPI connectivity testing.
  Alert Description
Diagnostic command: "Test-MAPIConnectivity -MonitoringContext:$true -PerConnectionTimeout:60 -AllConnectionsTimeout:90"
Count: 3
EventSourceName: MSExchange Monitoring MAPIConnectivity
0
 
MAS (MVE)EE Solution GuideCommented:
Thanks for the points
0
 
Andy MladAuthor Commented:
Test-Mapi now works fine on passive NOD
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.