SQL 2008 R2

All,

I have a virtual machine running Windows 2008 R2, that also has SQL 2008R2 installed.

I rebooted the server.

I was able to RDP into the Windows server like normal, once the reboot was finished.

However, it took SQL nearly ten minutes to allow connections. When I opened the SQL Management Console, I used Windows Authentication, like normal, but it wouldn't allow me in.  I even tried other accounts that had the passwords saved in cache, and they were not allowed in. I waited for a while, tried again, and then I was allowed in. I was not typing in the wrong password, as that information is stored in cache.

Please advise.
LVL 1
isamesAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kyle AbrahamsSenior .Net DeveloperCommented:
It could be that it took that long for SQL to start up.  Check out the Sql Service (service.msc) and make sure it's set to start and not a delayed start.
0
isamesAuthor Commented:
@LVL 41 Thanks for your response.

The SQL services are set automatic, and they were started.

I failed to mention that in my post.
0
Radhakrishnan RSenior Technical LeadCommented:
Hi,

is this server configured any static IP, DNS etc? if so, look at the DNS side. Try ping DNS and see if you get constant reply? if you configured any public DNS manually, try removing that and add local DNS address for fast resolution.
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Kyle AbrahamsSenior .Net DeveloperCommented:
Were you trying to connect to the server from outside the VM or inside the VM?

If you're outside the VM does the same thing happen inside the VM?  (EG: RDP then try to use ssms to login).
0
isamesAuthor Commented:
@LVL23

The server has statically assigned IP addresses and DNS.

I did a continuous ping against both DNS addresses, and they replied in 1ms
0
isamesAuthor Commented:
@Kyle Abrahams

Once the server is backup from reboot, I RDP into the VM, and then access SSMS.
0
65tdRetiredCommented:
Has SQL log been reviewed?

see link for information on the SQL ERROR log:
https://technet.microsoft.com/en-us/library/ms187885(v=sql.105).aspx
0
Kyle AbrahamsSenior .Net DeveloperCommented:
Does the box have an internet connection?

Try the following:
Go into IE, select Tools|Internet Options|Advanced
If “Check publisher’s certificate revocation” under the security node is checked, then uncheck it.

Explanation and credit:
https://blogs.msdn.microsoft.com/euanga/2006/07/11/faq-why-does-ssms-take-45s-to-start-up/

Also do you have any registered servers that you store in SSMS?  Are they all online?  If not remove the online ones and try again.
https://www.toadworld.com/platforms/sql-server/b/weblog/archive/2013/12/09/is-ssms-taking-longer-to-start
0
isamesAuthor Commented:
@65td
This is what I found when I checked the SQL logs:

SQL-Errors.png
0
65tdRetiredCommented:
View the log in a text editor, it should the start up and review how long SQL thinks it takes to be running.

Log location: Program Files\Microsoft SQL Server\MSSQL.n\MSSQL\LOG\ERRORLOG
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kyle AbrahamsSenior .Net DeveloperCommented:
Based on that error It's normal to see that if you're shutting down / starting up.  But it might also be a permissions error. Does the service account a custom one or are you using network service?
0
PberSolutions ArchitectCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Split:
-- 65td (https:#a42391354)
-- Kyle Abrahams (https:#a42391437)


If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

Pber
Experts-Exchange Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.