troubleshooting Question

Why adding default gateway for raspberry pi failed?

Avatar of MichaelBalack
MichaelBalackFlag for Singapore asked on
NetworkingUbuntuRaspberry PiHardwareOperating Systems
4 Comments1 Solution553 ViewsLast Modified:
This is using a raspberry-pi. My co-worker has defined a bridge called br-lan on top of the physical eth0. Please see attached docx for ifconfig command. Please also see the networking settings on /etc/network/interfaces, /etc/network/interfaces.d/br-lan, and /etc/dhcpcd.conf files. See the ip addressing settings of br-lan as follows:

       ip - 192.168.100.199
       mask - 255.255.255.0
      default gateway - 192.168.100.2
     dns - 203.211.152.66

However, the default gateway setting doesn't seem to work. Please see the results of route -n. I also try to set br-lan to dhcp, and the result is, eth0 grabs the ip - 192.168.100.199.

Appreciate for any help. Thanks in advance.
ASKER CERTIFIED SOLUTION
Dr. KlahnPrincipal Software Engineer

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 4 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 4 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros