Configure Putty & Xming

Dear Experts,
I have spent so much time trying X11 forwarding but still no success. Can you help me with it?

I have the sudo privilege and my system is Ubuntu 17.10. I try the instruction like
http://laptops.eng.uci.edu/software-installation/using-linux/how-to-configure-xming-putty
But not work. here is my error

hsu@hcavfb11:~$ xclock
Error: Can't open display:
hsu@hcavfb11:~$

Open in new window

rmtogetherAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
IN putty, you need to enable ssh, tunnel, X11 point it to localhost:a.b
Where a.b is the reference displayed when hovering over xming, commonly 0.0
Once you complete these,
Establishing a connection, running Echo $DISPLAY WILL CONFIRM THE MAPPING.
NOTE THE LOCALHOST:10.0 on the Linux side is the opening of the tunnel back through the x11tunnel to loca
Host:a.b.
Localhost on the Linux refers to itself, localhost on the X11 refers to the workstation from which the connection is initiated.
0
rmtogetherAuthor Commented:
Hi I

I try localhost:0.0 and localhost:10.0 both of them still not work. and When I do echo  $DISPLAY. There is nothing return.

hsu@hcavfb11:~$ echo  $DISPLAY

hsu@hcavfb11:~$ xclock
Error: Can't open display:
hsu@hcavfb11:~$

Open in new window

0
arnoldCommented:
You did not enable X11 in putty.

Ssh, X11 enable X11 forwarding, add the entry
Save season,  make sure the next time you connect the option is set.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

rmtogetherAuthor Commented:
Hi, arnold

I did enable x11 forwarding Snap2.png
0
serialbandCommented:
Maybe the sshd server is not set to allow X11 forwarding.  It also needs to be enabled before clients can display X11.
0
Peter SchultzSenior Network AdministratorCommented:
On your server, make sure /etc/ssh/sshd_config contains:

X11Forwarding yes
X11DisplayOffset 10

You may need to SIGHUP sshd so it picks up these changes.
cat /var/run/sshd.pid | xargs kill -1

don't forget to install xauth on your server


That should fix it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
arnoldCommented:
then as serialband and Ptere pointed out, confirm that your sshd_config allows X11 forwarding.
0
rmtogetherAuthor Commented:
thank you for the help!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SSH / Telnet Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.