Quickbooks Enterprise 2017 R1P - multiuser not working

Hello.

I am unable to get the Database Manager to run properly.  The error message is:

Network diagnostics failed, resolve errors and retry.

The only error listed is:  Windows firewall disabled exceptions not defined.  I disabled the built in firewall for now.  

If I open a user on this machine (the server) in multi-user mode (with or without the database manager running) then it will work fine in multi-user on all other machines.  But, if I don't, then multi-user cannot be used.

This is on a Windows Server 2016 Standard.  

I need to find a way to make this work properly.

Thanks. :)
LVL 1
Adam DIT Solutions DeveloperAsked:
Who is Participating?
 
JohnBusiness Consultant (Owner)Commented:
I would contact Intuit Support and open a case. I am not sure if your combination (brand new server, older QB) works.
0
 
Tom CieslikIT EngineerCommented:
Here

https://community.intuit.com/articles/1502150-error-h101-h202-h303-or-h505-when-opening-your-company-file

You can find manual how to manually open ports in Windows server firewall to let clients work in multiuser mode.
0
 
Adam DIT Solutions DeveloperAuthor Commented:
Thanks Tom.  Unfortunately I have already read that article and those steps did not solve my problem.

Also, my firewall is currently disabled so ports should not be a problem.

Any other thoughts?  Thanks. :)
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Adam DIT Solutions DeveloperAuthor Commented:
Update:

I looked through that article again and found something that almost helped.  By stopping the "Base Filtering Engine" service, the scan came back as successful. :)

However; I still have the same problem with a workstation in single user mode cannot switch to multi-user mode.  The error message says go to the server and turn on DB Manager - which, of course, I already have on.

Also, if I look at the Database Server tab, which should show me anyone logged into Quickbooks, it says no file are open, when in fact they are open.

Thanks. :)
0
 
JohnBusiness Consultant (Owner)Commented:
You probably should upgrade to QB V2018 and V2018 Server manager for Server 2016.  We are still using Server 2012 R2 and the QB Server Manager installed on this. We used QB V2017 without issue and now are using QB V2018.
0
 
Adam DIT Solutions DeveloperAuthor Commented:
Thanks John.  Probably should, but the upper brass at the moment would like to avoid that if possible.  Any other work-arounds? :)
0
 
masnrockCommented:
How exactly do you have things set up? Does the server has QB installed on it? It sounds as if you set up the server itself to host multi-user access rather than letting the DB Manager handle that, but only you know the answer to that.

For the firewall piece, here are the inbound TCP ports that need to be open: 8019, 56727, 55373-55377. If firewall errors still occur, then check out this article for tracking down undocumented ports:

Also try restarting both the BFE and Windows Firewall services.
1
 
Adam DIT Solutions DeveloperAuthor Commented:
Hi masnrock,

Yes, QB IS installed on the server because it is sometimes used in RDP.  DB Manager is installed on the server as well.

Firewall and BFE I can deal with later, both are off at the moment which is allowing DB Manager to show successful - otherwise it fails.

Thanks.
0
 
masnrockCommented:
Alright, but the question then becomes is the server set to be the host of multiuser mode? I'm hoping not, but that's the part that's not answered one way or the other.

I mentioned the two services for a reason NOT related to DB Manager: Turns out in some cases that it also causes problems with switching to multiuser in newer versions of Windows Server (2012 and 2016).
0
 
Adam DIT Solutions DeveloperAuthor Commented:
How can I tell if the server is set to be the host?  There is no option that says let it be the host.

I did read an article about QB 2015 having a problem with BFE and when I stopped that service QB DB Mgr was happy.
0
 
masnrockCommented:
Well, since you have QB installed on the server, you should be able to check in there. Check under File > Utilities.

What error do you get when trying to switch to multiuser mode on the workstations?
0
 
Adam DIT Solutions DeveloperAuthor Commented:
Error:  H202 - Quickbooks needs help connecting.

Yes, the server was setup to "host" multi-user access.  However; when I turned that off the DB Manager said there was a problem "Hosting was turned off" - go figure. :)

So, I turned that back on and DB Mgr is happy (which it was before with it begin turned on).

So, still the same problem.
0
 
masnrockCommented:
Have you tried uninstalling QB from the server entirely and only installing the Database Service Manager?
0
 
Adam DIT Solutions DeveloperAuthor Commented:
Thanks John.  I sent a similar note to the QB community support page.  No response yet.

Yes, I did masnrock.  Originally I just installed QB DB Mgr and it still had the errors, although I had not found the BFE issue.  But at this point I now need a copy on the server so a couple users can use it through RDP.

You wouldn't think it would be this difficult, especially since now the server manager is "happy" with the settings.  Why the H202??  It is not like it can't find the file.  All networking, netbios, etc., are good.  The file opens fine in single user or in multi-user IF I leave it open on the server as multi.  But, if I don't, then multi doesn't work.
0
 
JohnBusiness Consultant (Owner)Commented:
See what Support says (you can telephone them as well) . You may need the newer version of QB
0
 
masnrockCommented:
But at this point I now need a copy on the server so a couple users can use it through RDP.
I had a feeling this may come into play. I'm assuming (and correct me if I'm wrong) that the server is acting both as a file server and RDP server. If my assumption is correct, that's very disturbing from a security viewpoint, and I'm recommend separating the RDP server (putting into play an additional VM assuming that's an available option) from the file server.

I think when you have both installed, the DB server manager becomes dependent on that copy of QB. This is why I recommend just having the DB Server Manager on, but you can't do that until you separate RDP to another server (of course, more ideal to use RD Web Gateway)
0
 
d0ughb0yPresident / CEOCommented:
Thinking along the same lines as masnrock here: You say that the database manager software is turned on, on the server. Did you configure it? Is it "monitoring" the correct folder, with the QB data files in it? It has to be able to connected to that folder in order for it to work.

Also, did you check that the database service was running?
0
 
JohnBusiness Consultant (Owner)Commented:
You go to the QB Server Manager, the scan for the QB database which is in the folder that users map to. Once scanned, QB Client should be able to find it.
1
 
d0ughb0yPresident / CEOCommented:
That's what I was talking about, John.
0
 
Adam DIT Solutions DeveloperAuthor Commented:
Unfortunately, after talking with multiple reps at Intuit the last one told me QB2017 is NOT supported on Server 2016.  The workaround to make it work is to leave a "fake" user logged into the QB2017 ON the server and multi works fine for all others.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.