Exchange 2016 migration.Please help

Andy
Andy used Ask the Experts™
on
Hi,
I have a Exchange 2010 migration(to exchange 2016)
and my customer was impatient and has installed this morning Exchange 2016 without prerequisites(Unified Communications Managed,prepare AD,windows features..)...but didnt restart exchange 2016 after installation.
https://technet.microsoft.com/en-us/library/bb691354%28v=exchg.160%29.aspx?f=255&MSPPError=-2147217396

What should I do now?
Uninstall Exchange 2016,install prerequisites,install Exchange 2016 again?
Should I continue migration???
Any advice,hint please????
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
MASEE Solution Guide - Technical Dept Head
Most Valuable Expert 2017

Commented:
Hi Andy,
FYI without prerequisites you cannot install Exchange 2016.
I guess you already installed all the mandatory features required for Exxhange 2016
Jose Gabriel Ortega CastroCEO Faru Bonon IT /Top Rated Freelancer on Upwork / Photographer
Awarded 2018
Distinguished Expert 2018
Commented:
Nooo, don't uninstall the exchange because if you do so you will also need a clean up of the exchange objects in the AD using ADSI and sadly that's not for everyone.

So basically you can just install it if it's missing, I think that exchange 2016 installs the roles it needs and download the prerequisites if are required (not sure about this last). But you already have the package, so you will have to deal with it, and of course charge the client for doing so the extra time because if you haven't done it, I'm pretty sure that was for a reason.

So...
Go here: https://technet.microsoft.com/en-us/office/dn756393.aspx
Click the orange button and fill up the questions,
At the end, you will have a deliverable document and the steps to follow up the installation (migration) to 2016 smoothly.

(Double check the schema of the AD).

Author

Commented:
Maybe Exchange 2016 installation installs some prerequisites automatically?
I think /prepere AD runs automatically during exchange installation?
CompTIA Security+

Learn the essential functions of CompTIA Security+, which establishes the core knowledge required of any cybersecurity role and leads professionals into intermediate-level cybersecurity jobs.

Jose Gabriel Ortega CastroCEO Faru Bonon IT /Top Rated Freelancer on Upwork / Photographer
Awarded 2018
Distinguished Expert 2018

Commented:
Yes, it should have done it you just need to make sure it is ...
Other way exchange server just can't be install it, it will complain about it.

Ohh MAC already did answer that .
Architect
Distinguished Expert 2018
Commented:
Exchange setup runs prerequisite checker before start installation and pops up missing components
So your client must have gone through those pop ups and may have installed those additional components
Apart from external components, whatever server roles / features prerequisites and even AD schema modifications and AD preparation, that will be taken care by setup itself as long as you have appropriate rights (member of AD domain admins / enterprise admins and local admin of exchange server

All you need to do now is to try to logon to EAC and start checking if things are in place and if everything is in place, meaning you are able to logon to EAC, you are able to access database, you are able to access OWA, all services are running, then reboot the server and start further configuration like setting up co-existence with Exchange 2010, setup connectors, certificates, name spaces and so on

Mahesh.

Author

Commented:
OK.Thanks everyone for such great advices.
My client told me 10 minutes ago that during installation Exchange 2016 setup stopped and ask to download prerequisite and he downloaded some prerequisites,installed prerequisites and continued Exchange 2016 setup,but he cant remember what he installed.
My next step is to check what he installed and if everything its OK to continue migration.
Does anyone knows how to check if /prepereAD was executed.
Maybe this command?
"Exchange Schema Version = " + ([ADSI]("LDAP://CN=ms-Exch-Schema-Version-
Pt," + ([ADSI]"LDAP://RootDSE").schemaNamingContext)).rangeUpper
MaheshArchitect
Distinguished Expert 2018

Commented:
U can also check setup logs in system root drive of exchange server which gives you clear idea

Author

Commented:
Hi,
I checked all prerequisites and it seem that Exchange setup installed automatically all prerequisites except Unified Communications Managed API 4.0 which my client installed because Exchange setup provided link to install UCMA 4.0. during ex 2016 installation.
.NET Framework 4.6.2 is on by default on windows 2016 server.
Setup /prepare AD is also excecuted during setup because Forest (rangeUpper) is  15332(ex 2016 CU7)
https://eightwone.com/references/schema-versions/
So far,so good.
Tomorrow I will start migration (maybe :-) )

Author

Commented:
Thanks to everyone.
Migration completed.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial