Windows 2016 IIS 403 Error on Http to HTTPs Redirect

On one of our WIndows 2016 App servers that i not in production yet we are trying to setup http to https redirection. The site in question is a virtual directory. I have followed all of the artice for setting up OWA redirect and nothing is working.

HTTP works fine but as soon as I type in HTTPS I get the following message: "403 - Forbidden: Access is denied

You do not have permission to view this directory or page using the credentials that you supplied"
LVL 20
compdigit44Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jose Gabriel Ortega CEE Solution Guide - CEO Faru Bonon ITCommented:
Well, I don't know what article are you talking about.

You need to leave exchange server site alone in IIS
Open a new site in the port 80 with a dummy Folder (as location) and do the HTTP redirect to the https public site of OWA (1st check and second unchecked of both checks that you will get in the options of HTTP redirect feature).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Peter HutchisonSenior Network Systems SpecialistCommented:
0
Jose Gabriel Ortega CEE Solution Guide - CEO Faru Bonon ITCommented:
In my humble opinion, if you already have a built-in feature called "HTTP redirection" you don't need to install any additional software on the OS.
It's a matter of styles :)
0
compdigit44Author Commented:
After poking around with this further I found the setting I was setting in the GUI were note apply to the web config file. As soon as I updated the web config file to allow redirect it worked
0
Jose Gabriel Ortega CEE Solution Guide - CEO Faru Bonon ITCommented:
OK great select an answer or remove the question
Take care
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2016

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.