issue caused by wrong email address saved in autocomplete

We had email account
Say: for User A

Email address: 123@abc.com

Now i have added alias email address for User say "123.old@abc.com and set it as primary email address.

I have transferred "123@abc.com" email address to "User B" whose display name is same as user A.

Now users who have been emailing "123@abc.com" from outlook, if they email "123@abc.com", it goes to ""123.old@abc.com". I tried deleting  email address from autocomplete from one of user's outlook which fixed the issue for that particular user. So, i know it is causing by cached email address/autocomplete in outlook.

My question is,.. is there a way we can resolve this issue with out clearing autocomplete email address from each user's outlook. ????????
itadminhelpAsked:
Who is Participating?
 
itadminhelpAuthor Commented:
I found solution with with in link below:

X500 issue transfer fixed issue.
http://www.askme4tech.com/exchange-server-x500-address-amazing-thing-know
0
 
Olgierd UngehojerSenior Network AdministratorCommented:
I think that you have to do this per user. You can clean only one address on the list. If you want clean all you can run Outlook.exe /CleanAutoCompleteCache. You can use it on logon script and clean for all users when they login. PS script may look like this
Start-Process -FilePath 'C:\Program Files (x86)\Microsoft Office\Office15\Outlook.exe' -ArgumentList '/cleanautocompletecache','/recycle'
0
 
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
AFAIK Olgierd is correct, this is something you have to do for each mailbox individually.
0
 
itadminhelpAuthor Commented:
issue fixed (found solution in web)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.