Sharepoint IFRAME powerbi "Loading Data"

Hi,

I tried to embed a Power BI report using an iFrame in multiple way in Sharepoint 2013 onpremise. But still have the "loading data":



It's due to IE compatibility mode (need to be in IE11 or EDGE MODE)

I tried this : https://paultavares.wordpress.com/2015/01/20/how-to-render-a-sharepoint-page-in-ie-using-edge-mode-without-changing-the-master-page/ (not working or I miss something in his tuto)

and this: https://docs.microsoft.com/en-us/power-bi/report-server/quickstart-embed (not working)

And editing the masterpage: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\TEMPLATE\GLOBAL\default.master to add the meta tag : <meta http-equiv="X-UA-Compatible" content="IE=edge"/>.

Still the page is in IE10 mode when I check with F12:


Can you tell me where I should put the <meta http-equiv="X-UA-Compatible" content="IE=edge"/> or <meta http-equiv="X-UA-Compatible" content="IE=11"/> ?

here the aspx from my sharepoint page:
<%@ Register TagPrefix="WpNs0" Namespace="Microsoft.SharePoint.Portal.WebControls" Assembly="Microsoft.SharePoint.Portal, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"%>
<%@ Assembly Name="Microsoft.SharePoint, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"%> <%@ Page Language="C#" Inherits="Microsoft.SharePoint.WebPartPages.WikiEditPage" MasterPageFile="~masterurl/default.master"      MainContentID="PlaceHolderMain" meta:webpartpageexpansion="full" meta:progid="SharePoint.WebPartPage.Document" %>
<%@ Import Namespace="Microsoft.SharePoint.WebPartPages" %> <%@ Register Tagprefix="SharePoint" Namespace="Microsoft.SharePoint.WebControls" Assembly="Microsoft.SharePoint, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> <%@ Register Tagprefix="Utilities" Namespace="Microsoft.SharePoint.Utilities" Assembly="Microsoft.SharePoint, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %> <%@ Import Namespace="Microsoft.SharePoint" %> <%@ Assembly Name="Microsoft.Web.CommandUI, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>
<%@ Register Tagprefix="WebPartPages" Namespace="Microsoft.SharePoint.WebPartPages" Assembly="Microsoft.SharePoint, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %>
<asp:Content ContentPlaceHolderId="PlaceHolderPageTitle" runat="server">
	<SharePoint:ProjectProperty Property="Title" runat="server"/>&nbsp;- <SharePoint:ListItemProperty runat="server"/>
</asp:Content>
<asp:Content ContentPlaceHolderId="PlaceHolderPageImage" runat="server"><SharePoint:AlphaImage ID=onetidtpweb1 Src="/_layouts/15/images/wiki.png?rev=23" Width=145 Height=54 Alt="" Runat="server"/></asp:Content>
<asp:Content ContentPlaceHolderId="PlaceHolderAdditionalPageHead" runat="server">
	<meta name="CollaborationServer" content="SharePoint Team Web Site" />
	<SharePoint:ScriptBlock runat="server">
	var navBarHelpOverrideKey = &quot;WSSEndUser&quot;;
	</SharePoint:ScriptBlock>
	<SharePoint:RssLink runat="server"/>
	</asp:Content>
<asp:Content ContentPlaceHolderId="PlaceHolderMiniConsole" runat="server">
	<SharePoint:FormComponent TemplateName="WikiMiniConsole" ControlMode="Display" runat="server" id="WikiMiniConsole"/>
</asp:Content>
<asp:Content ContentPlaceHolderId="PlaceHolderLeftActions" runat="server">
	<SharePoint:RecentChangesMenu runat="server" id="RecentChanges"/>
</asp:Content>
<asp:Content ContentPlaceHolderId="PlaceHolderMain" runat="server">
	<span id="wikiPageNameDisplay" style="display: none;" runat="server">
		<SharePoint:ListItemProperty runat="server"/>
	</span>
	<span style="display:none;" id="wikiPageNameEdit" runat="server">
		<asp:TextBox id="wikiPageNameEditTextBox" runat="server"/>
	</span>
	<SharePoint:VersionedPlaceHolder UIVersion="4" runat="server">
		<SharePoint:SPRibbonButton
			id="btnWikiEdit"
			RibbonCommand="Ribbon.WikiPageTab.EditAndCheckout.SaveEdit.Menu.SaveEdit.Edit"
			runat="server"
			Text="edit"/>
		<SharePoint:SPRibbonButton
			id="btnWikiSave"
			RibbonCommand="Ribbon.WikiPageTab.EditAndCheckout.SaveEdit.Menu.SaveEdit.SaveAndStop"
			runat="server"
			Text="edit"/>
		<SharePoint:SPRibbonButton
			id="btnWikiRevert"
			RibbonCommand="Ribbon.WikiPageTab.EditAndCheckout.SaveEdit.Menu.SaveEdit.Revert"
			runat="server"
			Text="Revert"/>
	</SharePoint:VersionedPlaceHolder>
	<SharePoint:EmbeddedFormField id="WikiField" FieldName="WikiField" ControlMode="Display" runat="server"><div class="ExternalClassA767CEA288DF43BC876E08E6564A04EF">
            <table id="layoutsTable" style="width&#58;100%;"><tbody><tr style="vertical-align&#58;top;"><td colspan="2"><div class="ms-rte-layoutszone-outer" style="width&#58;100%;"><div class="ms-rte-layoutszone-inner" aria-label="Éditeur de texte enrichi">


<WebPartPages:ScriptEditorWebPart runat="server" Content="&lt;iframe width=&quot;800&quot; height=&quot;600&quot; src=&quot;https://sharepoint.contoso.com/si/Documents%20ITInterne/ie.aspx?http://srv-powerbi/reports/powerbi/Rapports/Support?rs:embed=true&quot; frameborder=&quot;0&quot; allowFullScreen=&quot;true&quot;&gt;&lt;/iframe&gt;" ChromeType="None" Description="Permet aux auteurs d&#39;ins&#233;rer des extraits ou des scripts HTML." ImportErrorMessage="Impossible d’importer ce composant WebPart." Title="&#201;diteur de script" ID="g_a33b837d_bbba_4695_b921_ba5c81a94f53" __MarkupType="vsattributemarkup" __WebPartId="{E0D20DE7-B49A-43B3-BCEA-2BD96837F4F1}" WebPart="true" __designer:IsClosed="false"></WebPartPages:ScriptEditorWebPart>

<p>&#160;</p>



<p>&#160;</p></div></div></td></tr><tr style="vertical-align&#58;top;"><td style="width&#58;49.95%;"><div class="ms-rte-layoutszone-outer" style="width&#58;100%;"><div class="ms-rte-layoutszone-inner" aria-label="Éditeur de texte enrichi">




<WpNs0:SiteFeedWebPart runat="server" __MarkupType="xmlmarkup" WebPart="true" __WebPartId="{6577C5B7-65EE-4D07-B598-2E3C7DCBCC0D}" >
<WebPart xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/WebPart/v2">
  <Title>Flux de site</Title>
  <FrameType>None</FrameType>
  <Description>Le flux de site contient des conversations de microblog sur un site de groupe.</Description>
  <IsIncluded>true</IsIncluded>
  <ZoneID>wpz</ZoneID>
  <PartOrder>2</PartOrder>
  <FrameState>Normal</FrameState>
  <Height />
  <Width />
  <AllowRemove>true</AllowRemove>
  <AllowZoneChange>true</AllowZoneChange>
  <AllowMinimize>true</AllowMinimize>
  <AllowConnect>true</AllowConnect>
  <AllowEdit>true</AllowEdit>
  <AllowHide>true</AllowHide>
  <IsVisible>true</IsVisible>
  <DetailLink />
  <HelpLink />
  <HelpMode>Modeless</HelpMode>
  <Dir>Default</Dir>
  <PartImageSmall />
  <MissingAssembly>Impossible d'importer ce composant WebPart.</MissingAssembly>
  <PartImageLarge />
  <IsIncludedFilter />
  <ExportControlledProperties>true</ExportControlledProperties>
  <ConnectionID>00000000-0000-0000-0000-000000000000</ConnectionID>
  <ID>g_5a25a3eb_055a_4340_97fb_fd0e51c90be8</ID>
</WebPart>
</WpNs0:SiteFeedWebPart>
</div></div></td><td class="ms-wiki-columnSpacing" style="width&#58;49.95%;"><div class="ms-rte-layoutszone-outer" style="width&#58;100%;"><div class="ms-rte-layoutszone-inner" aria-label="Éditeur de texte enrichi">
<p>&#160;</p>

<p>&#160;</p></div></div></td></tr></tbody></table>
            <span id="layoutsData" style="display&#58;none;">true,false,2</span></div></SharePoint:EmbeddedFormField>
	<WebPartPages:WebPartZone runat="server" ID="Bottom" CssClass="ms-hide" Title="loc:Bottom"><ZoneTemplate><WpNs0:SiteFeedWebPart runat="server" __MarkupType="xmlmarkup" WebPart="true" __WebPartId="{7CCBBF80-8976-46F9-AFF2-55CF40B5748D}" >
<WebPart xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/WebPart/v2">
  <Title>Flux de site</Title>
  <FrameType>None</FrameType>
  <Description>Le flux de site contient des conversations de microblog sur un site de groupe.</Description>
  <IsIncluded>true</IsIncluded>
  <ZoneID>Bottom</ZoneID>
  <PartOrder>1</PartOrder>
  <FrameState>Normal</FrameState>
  <Height />
  <Width />
  <AllowRemove>true</AllowRemove>
  <AllowZoneChange>true</AllowZoneChange>
  <AllowMinimize>true</AllowMinimize>
  <AllowConnect>true</AllowConnect>
  <AllowEdit>true</AllowEdit>
  <AllowHide>true</AllowHide>
  <IsVisible>true</IsVisible>
  <DetailLink />
  <HelpLink />
  <HelpMode>Modeless</HelpMode>
  <Dir>Default</Dir>
  <PartImageSmall />
  <MissingAssembly>Impossible d'importer ce composant WebPart.</MissingAssembly>
  <PartImageLarge />
  <IsIncludedFilter />
  <ExportControlledProperties>true</ExportControlledProperties>
  <ConnectionID>00000000-0000-0000-0000-000000000000</ConnectionID>
  <ID>g_594a8184_56d5_4550_ba72_83c4f43277ab</ID>
</WebPart>
</WpNs0:SiteFeedWebPart>
</ZoneTemplate></WebPartPages:WebPartZone>
</asp:Content>

Open in new window

PinpindesboisAsked:
Who is Participating?
 
PinpindesboisConnect With a Mentor Author Commented:
Solution : MasterPageFile="~masterurl/default.master"

It's not default.master taken. It was the oslo.master. I replaced the IE=10 with IE=edge.
On SP designer just right click on every master and look for the one that you can't set by default.
Then edit the .html bound to the master.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.